archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Horwitz" <mike.horw...@gmail.com>
Subject Re: HTTP 409: error deploying file to managed repository
Date Fri, 15 Dec 2006 16:12:13 GMT
Hi,

Have you granted your user the role repository manager on the specified
repository? I see you are getting an Authorization Denied at the top of the
log file.

Regards

Mike Horwitz


On 12/15/06, Stefan Hübner <sthuebner@googlemail.com> wrote:
>
> Hey,
>
> can anybody help with following issue? I try to deploy a library to
> Repository managed by Archiva (r486213) using dav. All I get is HTTP
> code 409. What's wrong here?
>
> The server-settings provide valid user credentials (which is confirmed
> in archiva's logs - see below).
>
> Maven returns the following error:
>
> [INFO] Scanning for projects...
> [INFO] Searching repository for plugin with prefix: 'deploy'.
> [INFO]
>
> ----------------------------------------------------------------------------
> [INFO] Building Deployment Helper
> [INFO]    task-segment: [deploy:deploy-file] (aggregator-style)
> [INFO]
>
> ----------------------------------------------------------------------------
> [INFO] [deploy:deploy-file]
> Uploading:
> http://vm-mavn1/archiva/repository/test/test/test/1.0.0/test-1.0.0.jar
> 216K uploaded
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error deploying artifact: Unable to transfer file.
> HttpURLConnection
> returned the response code: 409
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 4 seconds
> [INFO] Finished at: Fri Dec 15 16:47:23 CET 2006
> [INFO] Final Memory: 3M/6M
> [INFO]
> ------------------------------------------------------------------------
>
>
> the corresponding logs in archiva's log:
>
> 2006-12-15 16:47:21,040 [TP-Processor1] DEBUG
> RBACManager:cached             -
> building user permission map
> 2006-12-15 16:47:21,168 [TP-Processor1]
> WARN  PlexusServlet:repositoryAccess -
> Authorization Denied [ip=192.168.70.107,isWriteRequest=true,pe
> mission=archiva-upload-repository] : no matching permissions
> 2006-12-15 16:47:22,407 [TP-Processor11] DEBUG
> Authenticator:user-manager     -
> Authenticate: PasswordBasedAuthenticationDataSource[principal
> snhr,password=***]
> 2006-12-15 16:47:22,414 [TP-Processor11] DEBUG
> Authenticator:user-manager     -
> PasswordEncoder: org.codehaus.plexus.security.policy.encoders
> SHA256PasswordEncoder
> 2006-12-15 16:47:22,415 [TP-Processor11] DEBUG
> Authenticator:user-manager     -
> User snhr provided a valid password
> 2006-12-15 16:47:22,423 [TP-Processor11] DEBUG
> SecuritySystem:default         -
> authnManager.authenticate() result: AuthenticationResult[prin
> ipal=snhr,isAuthenticated=true,exception=<null>]
> 2006-12-15 16:47:22,423 [TP-Processor11] DEBUG
> SecuritySystem:default         -
> User 'snhr' authenticated.
> 2006-12-15 16:47:22,429 [TP-Processor11] DEBUG
> SecuritySystem:default         -
> User 'snhr' exists.
> 2006-12-15 16:47:22,435 [TP-Processor11] DEBUG
> SecuritySystem:default         -
> User: username = 'snhr'
> password = 'null'
> encodedPassword = 'rJeH/fqFAFhrZC6fE9DatgPjcI2EcakDTS5/YRceaoo='
> fullName = 'Stefan H?'
> email = 'snhr@incowia.de'
> locked = 'false'
> permanent = 'false'
> validated = 'false'
> passwordChangeRequired = 'true'
> 2006-12-15 16:47:22,435 [TP-Processor11] DEBUG
> RBACManager:cached             -
> building user permission map
> 2006-12-15 16:47:22,520 [TP-Processor11] DEBUG
> Authorizer:rbac                -
> checking permission archiva-upload-repository-test
> 2006-12-15 16:47:22,528 [TP-Processor11] DEBUG
> AutoLoginCookies               -
> Remember Me Cookie Not Found: securityRememberMe
> 2006-12-15 16:47:22,528 [TP-Processor11] DEBUG
> AutoLoginCookies               -
> Single Sign On Cookie Not Found: securitySingleSignOn
> 2006-12-15 16:47:22,602 [TP-Processor11] DEBUG
> RBACManager:cached             -
> using cached user permission map
> 2006-12-15 16:47:22,608 [TP-Processor11] DEBUG
> RBACManager:cached             -
> using cached user permission map
> 2006-12-15 16:47:22,614 [TP-Processor11] DEBUG
> RBACManager:cached             -
> using cached user permission map
>
>
> Thanks for any hints!
>
> -Stefan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message