archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohni, Daniel" <daniel.mo...@ch.unisys.com>
Subject RE: observations on daily build of 20061115
Date Thu, 16 Nov 2006 06:54:42 GMT
Hi Brett

answers inline..
 
> -----Original Message-----
> From: Brett Porter [mailto:brett@apache.org] 
> Sent: Thursday, November 16, 2006 4:09 AM
> To: archiva-users@maven.apache.org
> Subject: Re: observations on daily build of 20061115

 
> Would you mind contributing by:
> - putting the bugs found in jira

I opened 2 issues in jira MRM-222 and MRM-223 hope I did this
correctly....

> - adding your configuration tips to the wiki?

what wiki do you mean ?
maybe this should also go to the getting started page ;-)

Daniel


> Much appreciated!
> 
> - Brett
> 
> On 16/11/2006, at 1:31 AM, Mohni, Daniel wrote:
> 
> > Hello
> >
> > today I rebuild archiva to check the current state,
> > after some testing of the webapp in tomcat I decide
> > to install this on our development environment.
> >
> > just some hints about configuration of the repositories
> > in the settings.xml
> >
> > -> proxied repositories should be accessed using the 'proxy'
> >    in the url to get the download from remote servers to work
> >
> >    <repository>
> >       <id>maven-release</id>
> >       <url>http://archiva/proxy/maven_release</url>
> >       <snapshots>
> >          <enabled>false</enabled>
> >       </snapshots>
> >    </repository>
> >
> > -> repository that are not proxied should be accessed
> >    with 'repository' in the url
> >
> >    <repository>
> >       <id>internal-release</id>
> >       <url>http://archiva/repository/internal_release</url>
> >       <snapshots>
> >          <enabled>false</enabled>
> >       </snapshots>
> >    </repository>
> >
> > what is not working:
> >
> > the download button when browsing artefacts is not working,
> > but I don't realy need this...
> >
> > repository access is not working with . in the url
> >
> > -> 
> ../repository/3p_release/net.sf.ehcache/ehcache/1.2/ehcache-1.2.jar
> >
> > this works with the proxy access
> >
> > -> ../proxy/maven_release/net.sf.ehcache/ehcache/1.2/ehcache-1.2.jar
> >
> > I'll try dav upload tomorrow if I find the way to configure it ;-)
> > maybe I have to setup a user in archiva and give hime the correct
> > role...
> >
> > -Daniel
> 

Mime
View raw message