archiva-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Duncan" <stephen.dun...@gmail.com>
Subject Re: Checksum problem
Date Mon, 18 Sep 2006 18:32:29 GMT
I've noticed the same thing.  I started trying to use Archiva as a
proxy, and noticed that items failed to resolve due to checksum
errors.  I don't have a problem with that in theory, but there appear
to be several plugins on the central repo with bad checksums.  I
opened an issue about the one I noticed (the war plugin), but I've
noticed some others when using Maven regularly.  (Aside: How could I
configure the central repository to treat checksum errors as failures
normally in settings.xml?)  Is there some way to maybe due a scan of
central to find out the list of invalid checksums?

-Stephen

On 9/18/06, VAUCHER Laurent <VAUCHER@fermat.eu> wrote:
>   Trying to do a 'mvn archetype:create', I encounter checksum errors
> from the IBiblio repository.
> When Maven is configured to go directly to IBiblio, I get a warning, but
> when I configure a proxy, it's archiva that gets the warning and it
> seems to treat it as a blocking error. It does not deliver the plugin to
> the maven 'client'.
>
>   Is there a way to configure it to be less picky?
>   Are files on IBiblio corrupted?
>   Does anybody care? (The files in question seem to be several months
> old 1.0-alpha-4).
>
>
> Laurent.
>
>


-- 
Stephen Duncan Jr
www.stephenduncanjr.com

Mime
View raw message