archiva-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pedro Macedo Leite (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MRM-1485) LDAP authentication attempts to change password on first login.
Date Tue, 09 Aug 2011 12:55:43 GMT

    [ https://jira.codehaus.org/browse/MRM-1485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=275347#comment-275347
] 

Pedro Macedo Leite commented on MRM-1485:
-----------------------------------------

I removed the option spoken, however it did not work.
I created a new installation and copied the data, and yet was not. I created an installation
from scratch and gave the same erro.kkk

As if I have a bug?

> LDAP authentication attempts to change password on first login.
> ---------------------------------------------------------------
>
>                 Key: MRM-1485
>                 URL: https://jira.codehaus.org/browse/MRM-1485
>             Project: Archiva
>          Issue Type: Bug
>    Affects Versions: 1.3.2
>            Reporter: Pedro Macedo Leite
>            Priority: Critical
>         Attachments: security.properties
>
>
> I have a development environment on the archive and Mavin.
> And I'm trying to put this environment authenticating to OpenLDAP. By doing could only
setting in the file security.properties. The configuration is below:
> user.manager.impl=ldap
> ldap.bind.authenticator.enabled=true
> redback.default.admin=admin
> ldap.config.hostname=IP_server
> ldap.config.port=389
> ldap.config.base.dn=dc=domain,dc=com,dc=br
> ldap.config.context.factory=com.sun.jndi.ldap.LdapCtxFactory
> ldap.config.bind.dn=cn=admin,dc=domain,dc=com,dc=br
> ldap.config.password=XXXXXXXXX
> ldap.config.mapper.attribute.email=mail
> ldap.config.mapper.attribute.fullname=uid
> ldap.config.mapper.attribute.password=userPassword
> ldap.config.mapper.attribute.user.id=uid
> ldap.config.mapper.attribute.user.object.class=simpleSecurityObject
> security.policy.password.expiration.enabled=false
> security.policy.strict.enforcement.enabled=false
> security.policy.strict.force.password.change.enabled=false
> security.policy.unlockable.accounts=admin
> security.policy.allowed.login.attempt=1000
> After this configuration, I could authenticate to openldap. but when the system right
the first time it asks me to change the password. Already sent email to the maillist and everyone
told me it was bug, because the option:
> security.policy.strict.force.password.change.enabled = false
> is already configured.
> My version is 1.3, however tested on 1.3.5 and also did the same.
> How to authenticate to OpenLDAP is not asking to change password the first time? Because
the option shown above does not work?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message