archiva-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabrice Daugan (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MRM-905) EL Expression failed with empty/not functions
Date Thu, 14 Aug 2008 18:00:27 GMT

    [ http://jira.codehaus.org/browse/MRM-905?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=145067#action_145067
] 

Fabrice Daugan commented on MRM-905:
------------------------------------

Also, i think there are som common code with Contunuum, since the same error (but non blocker)
occurs in the header.

> EL Expression failed with empty/not functions
> ---------------------------------------------
>
>                 Key: MRM-905
>                 URL: http://jira.codehaus.org/browse/MRM-905
>             Project: Archiva
>          Issue Type: Bug
>          Components: web application
>    Affects Versions: 1.1
>         Environment: Windows XP SP3 FR
> java (JDK) "1.6.0_07"
> apache tomcat "6.0.18"
> activation-1.1.jar
> mail-1.4.jar
> derby-10.1.3.1.jar
>            Reporter: Fabrice Daugan
>            Assignee: Maria Odea Ching
>            Priority: Blocker
>             Fix For: 1.1.2
>
>         Attachments: catalina.2008-08-10.log, localhost.2008-08-10.log
>
>
> After installing as Wiki said, as a tomcat WAR, i get parsing error in some JSP/TAG code.
> Some examples :
> org.apache.jasper.JasperException: /WEB-INF/jsp/components/companyLogo.jsp(22,0) "${!empty(organisationLogo)}"
contient d'incorrecte(s) expression(s): javax.el.ELException: Function ':empty' not found
> org.apache.jasper.JasperException: /WEB-INF/tags/currentWWUrl.tag(29,0) "${!empty(action)
&& !empty(namespace)}" contient d'incorrecte(s) expression(s): javax.el.ELException:
Function ':empty' not found
> I've added logs as attachments.
> The workaround is very simple : 
> replace EL exepressions containing "empty(" with "empty (", and  "not(" with "not ("
as EL expression requires.
> This is a VERY strange error since i've successufully setup Archiva on my profesionnal
server, and i got these error on two distinct personnal systems.
> I'll check the professionnal/personnal system differences.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message