archiva-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robin Roos (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (MRM-728) After successful admin login archiva reacts as if user is guest
Date Fri, 07 Mar 2008 11:42:28 GMT

    [ http://jira.codehaus.org/browse/MRM-728?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_126441
] 

Robin Roos commented on MRM-728:
--------------------------------

My browser is IE version 6.0.2900.2180.xpsp_sp2_gdr.070227-2254 which I take to mean "IE 6.0
SP 2".

The bank does not permit Firefox (which intrigues me, as I see Firefox as less of a risk than
IE !).

The logs (archiva.log) did not show anything when I signed on "successfully" but did have
messages that indicated "unsuccessful login" (at which point I got to the unsuccessful login
page).

n the successful login scenario the archiva.log has no additional entries and I am directed
back to the opening page with only three available functions.

The server is given as:

uname -a
Linux invldnlspare1 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64 x86_64 x86_64
GNU/Linux


> After successful admin login archiva reacts as if user is guest
> ---------------------------------------------------------------
>
>                 Key: MRM-728
>                 URL: http://jira.codehaus.org/browse/MRM-728
>             Project: Archiva
>          Issue Type: Bug
>    Affects Versions: 1.0.1
>         Environment: linux
>            Reporter: Robin Roos
>             Fix For: 1.0.x
>
>
> I ran Archiva on my windows box and, after configuring the admin user, I was able to
login.  The header of the web page identified me as Administrator (admin) and I could see
all the expected functions on the left hand frame.  So far so good.
> I had Archiva installed on a linux box and started.  I surfed to the box from Windows
and configured the admin user.  But when I logged in as admin I got a page with only Search/FindArtifact/Browse
functions.  The header page reads "Login - Register".  It is as if I am not logged in and
am seeing the guest functions.  Note that if I log in with a deliberately incorrect password
then I get an error message as expected.  But logging in with the right credentials appears
to fail silently.
> As a result I cannot deploy any artifacts into Archiva, I cannot roll out the maven/subversion/archiva
based edition of our in-house project, and I fear my time is limited!

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message