archiva-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacques REYNARD (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MRM-631) network proxy is always used when defined
Date Tue, 18 Dec 2007 09:37:57 GMT
network proxy is always used when defined
-----------------------------------------

                 Key: MRM-631
                 URL: http://jira.codehaus.org/browse/MRM-631
             Project: Archiva
          Issue Type: Bug
          Components: remote proxy
    Affects Versions: 1.0
         Environment: Linux and Windows with JRE 1.5
            Reporter: Jacques REYNARD
         Attachments: archiva.xml

I've installed Archiva 1.0 as a Maven proxy repository for internet  and corporate repositories.
I've added the remote Internet Repositories, the network proxy and the proxy connectors.

It works well for the internet repositories but when Archiva tries to connect to the corporate
repository in the same subnetwork, Archiva uses
the network proxy despite the proxy connector is set to Direct Connection. 

If no proxy connectors is defined, Archiva didn't try to get data form the corporate repository.

If no network proxy is defined, Archiva can contact the corporate repository but not the Internet
ones.

I've done a test with network capture (wireshark ex ethereal) to confirm the network proxy
defined is used. And the result confirm my opinion, the proxy is used.

I attach the archiva.xml configuration file in order to check it. 
The corporate repository is localrepo and is available in http form the archiva server using
lynx,  wget and telnet. 

Thanks for your help


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message