archiva-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nicolas de loof (JIRA)" <j...@codehaus.org>
Subject [jira] Created: (MRM-629) NullPointer when setting corporate POM on a fresh archvia install
Date Mon, 17 Dec 2007 08:52:57 GMT
NullPointer when setting corporate POM on a fresh archvia install
-----------------------------------------------------------------

                 Key: MRM-629
                 URL: http://jira.codehaus.org/browse/MRM-629
             Project: Archiva
          Issue Type: Bug
          Components: web application
    Affects Versions: 1.0
         Environment: archiva deployed as a war on tomcat 5.5
            Reporter: nicolas de loof
            Priority: Minor


Tryning to set a corporate POM fails with a NullPointerException

The maven-shared-application configuration expect a configuration to exist as either org.apache.maven.shared.app.user
or org.apache.maven.shared.app.base. The first one is declared in archvia application.xml
as "config-forceCreate="true"", so it SHOULD have been created, but is absent from my ${user.home}/.m2

This may be a plexus-registry-provider bug, or a commons-configuration bug.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message