archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sascha Vogt <sascha.v...@gmail.com>
Subject Re: LDAP configuration
Date Thu, 07 Nov 2013 09:15:01 GMT
Hi,

we investigated a bit further, and one thing was quite easy to find: The
config needs to expose the group class in order to list all the groups.
Nevertheless the queries if a user is in a particular group seems to
fail. We're in the process of debugging and will let you know, what we
find out.

Greetings
-Sascha-

Am 30.10.2013 10:29, schrieb Sascha Vogt:
> Hi all,
> 
> yesterday I installed the latest 2.0.0-SNAPSHOT from Jenkins
> (https://builds.apache.org/job/archiva-all-maven-3.x-jdk-1.6/ - hope
> that's the correct one) and tried to configure LDAP against our AD.
> 
> Some things I noticed:
> 
> * ldap.config.mapper.attribute.user.filter isn't exposed in the properties
> 
> * If I manually add a filter to the archiva.xml and enter a filter like:
> (|(sAMAccountName=<special-user>)(memberOf=CN=Entwicklung,OU=Gruppen,DC=<our-domain>,DC=de))
> the property gets cut at the first "," and the filter is then obviously
> broken.
> 
> * Not sure what's going wrong here, but I don't see any LDAP groups (for
> a role mapping), when I click on the green <plus> button, I get an
> error: [redback-runtime-ldap-group-mapping.role.mandatory]
> 
> * My log is silent about all this, maybe it's related to those errors in
> the wrapper*.log:
> INFO   | jvm 1    | 2013/10/30 10:24:17 | 2013-10-30 10:24:17,193 ERROR
> Unable to locate appender auditlog for logger org.apache.archiva.AuditLog
> INFO   | jvm 1    | 2013/10/30 10:24:17 | 2013-10-30 10:24:17,194 ERROR
> Unable to locate appender redbackAuditLog for logger
> org.apache.archiva.redback.struts2.action.AuditEvent
> INFO   | jvm 1    | 2013/10/30 10:24:17 | 2013-10-30 10:24:17,195 ERROR
> Unable to locate appender rolling for logger
> 
> 
> Should I open tickets for those issues?
> 
> Greetings
> -Sascha-
> 


Mime
View raw message