archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: SLF4J errors ?
Date Sat, 02 Mar 2013 10:40:51 GMT
It would be good to avoid the conflict, but as you can see here it picked the right one so
the warning shouldn't be significant (the link in the error has more info).

On 02/03/2013, at 9:37 AM, Chris Graham <chrisgwarp@gmail.com> wrote:

> In using M4-SNAPSHOT on WAS8, in looking in the system log, I saw:
> 
> [3/2/13 8:45:57:460 EST] 00000010 SystemErr     R SLF4J: Class path
> contains multiple SLF4J bindings.
> [3/2/13 8:45:57:461 EST] 00000010 SystemErr     R SLF4J: Found binding in
> [wsjar:file:/opt/IBM/WebSphere/AppServer/profiles/AppSrv01/installedApps/buildCell01/archiva-1_4-M4-SNAPSHOT_war.ear/archiva-webapp-1.4-M4-SNAPSHOT-1989.war/WEB-INF/lib/log4j-slf4j-impl-2.0-beta4.jar!/org/slf4j/impl/StaticLoggerBinder.class]
> [3/2/13 8:45:57:461 EST] 00000010 SystemErr     R SLF4J: Found binding in
> [bundleresource://481.fwk-786195778:1/org/slf4j/impl/StaticLoggerBinder.class]
> [3/2/13 8:45:57:461 EST] 00000010 SystemErr     R SLF4J: See
> http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
> [3/2/13 8:45:57:465 EST] 00000010 SystemErr     R SLF4J: Actual binding is
> of type [org.slf4j.helpers.Log4JLoggerFactory]
> 
> 
> I'm not sure of it's significant or not.
> 
> -Chris

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/
http://au.linkedin.com/in/brettporter
http://twitter.com/brettporter






Mime
View raw message