archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy <ol...@apache.org>
Subject Re: Archiva memory settings and stability
Date Thu, 05 Jan 2012 08:08:32 GMT
2012/1/5 Brett Porter <brett@apache.org>:
> Hi,
>
> In MRM-1549, the -Xms was increased to 512m. This is very high for a starting point -
would it be better to use the default settings, but let it grow to the upper setting? It is
quite costly on memory when I run it on my local machine.
Not xmas RAM ? :-)
>
> A couple of years back I did a lot of profiling to try and get it as lean as possible,
so that we could run a minimal instance - this is something I'd like to do again before 1.4.
Between the large number of classes to load and other memory use it's becoming impractical
to run that way again :)
>
I usually like having -Xms to prevent later slower allocation.
But as it's something easily configurable: no problem.

BTW removing xmlrpc will decrease number of loaded classes. (and
moving to a plain html/js will remove struts classes loading too: more
longer task :-) ).

> Also, I've noticed that the latest milestones are still not very stable on vmbuild, restarting
once or twice a day. Is anyone else seeing similar problems?

No I'm not aware of that.
Any logs or stacktrace or dump available ?

>
> Cheers,
> Brett
>
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
> http://twitter.com/brettporter
>
>
>
>
>



-- 
Olivier Lamy
Talend: http://coders.talend.com
http://twitter.com/olamy | http://linkedin.com/in/olamy

Mime
View raw message