archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Franken <alexfran...@gmail.com>
Subject Re: repository group index
Date Fri, 29 Apr 2011 14:23:58 GMT
It appears that I found the answer to my question by searching the mail
archives.  This support is huge for organizations using repository groups.

http://www.mail-archive.com/users@archiva.apache.org/msg01381.html

*Re: Nexus index for repository group*

*Gwen Harold Autencio*
Wed, 12 May 2010 20:08:06 -0700

As I have tried, archiva right now only handles the index of the first

repository of the repository group. Issues MRM-1318 and MRM-815 are not
fixed

yet that would handle the index of the repository group.



...



http://jira.codehaus.org/browse/MRM-1318

http://jira.codehaus.org/browse/MRM-815



On Fri, Apr 29, 2011 at 8:57 AM, Alex Franken <alexfranken@gmail.com> wrote:

> I have set up an Archiva repository group.  Within that group I have two
> repositories (internal releases – excludes snapshots, snapshots – excludes
> releases).
>
> My IDE (Eclipse/m2eclipse) is pulling down an index but it does not include
> any snapshots (when trying to “Add Dependency”).  This tells me that archiva
> is publishing an index that m2eclipse can read.  The timestamps for the
> index files in both of my repositories look current (scanning every hour).
> Could it be that the index returned from the repository group request is
> only returning the “internal” repository index?
>
>
> Could someone provide any insight on how the indexing mechanism w/
> repository groups?
>
>
> eclipse (helios), m2eclipse latest version, archiva 1.3.2
>
>
>
> Thanks.
>
> Alex
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message