archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Selenium test failures on trunk (was: [VOTE] Release Archiva 1.3)
Date Mon, 15 Feb 2010 04:22:32 GMT
For the record, I was able to reproduce this, and Deng pointed out that it only occurs when
you build with the root as a multi-module project. When you build the webapp-tests project
on its own, it is fine. I'll file that in JIRA.

Otherwise, the tests seem to be working again now, so I've closed MRM-1322.

- Brett

On 04/02/2010, at 1:19 PM, Deng Ching wrote:

> Sorry, I missed replying to this one :)
> 
> I'm still getting the same error in the selenium tests in trunk when I run
> it from the root with -Pit and even if I already deleted the cargo-installs
> directory. I'm also using Maven 2.2.1 btw :)
> 
> Thanks,
> Deng
> 
> On Wed, Jan 20, 2010 at 12:11 AM, Brett Porter <brett@apache.org> wrote:
> 
>> I fixed some problems simply by deleting the cargo-installs directory
>> (there was some junk in Tomcat's common/lib).
>> 
>> If you've already done that, we'll need to look closer at the difference
>> here. Are you also using Maven 2.2.1?
>> 
>> - Brett
>> 
>> On 19/01/2010, at 10:00 PM, Deng Ching wrote:
>> 
>>> I'm also getting the same error when I built from 1.3 tag :(
>>> 
>>> Thanks,
>>> Deng
>>> 
>>> On Tue, Jan 19, 2010 at 2:15 PM, Deng Ching <oching@apache.org> wrote:
>>> 
>>>> I see the following error in archiva.log:
>>>> 
>>>> 2010-01-18 18:32:18,321 [main] ERROR
>>>> org.springframework.web.context.ContextLoader  - Context initialization
>>>> failed
>>>> org.springframework.beans.factory.BeanDefinitionStoreException: Invalid
>>>> bean definition with name 'mavenSettingsBuilder' defined in null: Could
>> not
>>>> resolve placeholder 'maven.home'
>>>>   at
>>>> 
>> org.springframework.beans.factory.config.PropertyPlaceholderConfigurer.processProperties(PropertyPlaceholderConfigurer.java:268)
>>>>   at
>>>> 
>> org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:75)
>>>>   at
>>>> 
>> org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:553)
>>>>   at
>>>> 
>> org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:527)
>>>>   at
>>>> 
>> org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:362)
>>>>   at
>>>> 
>> org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:255)
>>>>   at
>>>> 
>> org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:199)
>>>>   at
>>>> 
>> org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:45)
>>>>   at
>>>> 
>> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
>>>>   at
>>>> 
>> org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
>>>>   at
>>>> 
>> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
>>>>   at
>>>> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
>>>>   at
>>>> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
>>>>   at
>>>> 
>> org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
>>>>   at
>>>> 
>> org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
>>>>   at
>>>> org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
>>>>   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1150)
>>>>   at
>>>> 
>> org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
>>>>   at
>>>> 
>> org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
>>>>   at
>>>> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
>>>>   at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
>>>>   at
>>>> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
>>>>   at
>>>> org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
>>>>   at
>>>> org.apache.catalina.core.StandardService.start(StandardService.java:448)
>>>>   at
>>>> org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
>>>>   at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
>>>>   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>   at
>>>> 
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>   at
>>>> 
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>   at java.lang.reflect.Method.invoke(Method.java:592)
>>>>   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
>>>>   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
>>>> 
>>>> I'm checking the tag if I'll get the same results..
>>>> 
>>>> Thanks,
>>>> Deng
>>>> 
>>>> 
>>>> On Mon, Jan 18, 2010 at 7:29 PM, Brett Porter <brett@apache.org> wrote:
>>>> 
>>>>> 
>>>>> On 18/01/2010, at 9:34 PM, Deng Ching wrote:
>>>>> 
>>>>>> On Mon, Jan 18, 2010 at 6:25 PM, Brett Porter <brett@apache.org>
>> wrote:
>>>>>> 
>>>>>>> 
>>>>>>> On 18/01/2010, at 9:10 PM, Deng Ching wrote:
>>>>>>> 
>>>>>>>> There were a number of webapp tests which failed for me in
trunk but
>>>>> the
>>>>>>>> webapp was being loaded.
>>>>>>> 
>>>>>>> you got the 60sec timeouts?
>>>>>>> 
>>>>>> 
>>>>>> No, I'm getting 404s when http://localhost:9696/archiva is accessed..
>>>>> 
>>>>> what's in your tomcat / archiva logs?
>>>>> 
>>>>> - Brett
>>>>> 
>>>>> --
>>>>> Brett Porter
>>>>> brett@apache.org
>>>>> http://brettporter.wordpress.com/
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>>> 
>>>> 
>> 
>> --
>> Brett Porter
>> brett@apache.org
>> http://brettporter.wordpress.com/
>> 
>> 
>> 
>> 
>> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





Mime
View raw message