archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Browsing in the MRM-1025 branch
Date Tue, 22 Dec 2009 10:38:00 GMT

On 22/12/2009, at 3:49 PM, Brett Porter wrote:

> 
> On 22/12/2009, at 3:22 PM, Wendy Smoak wrote:
> 
>> On Mon, Dec 21, 2009 at 9:01 PM, Brett Porter <brett@apache.org> wrote:
>> 
>>> Yeah, that sounds like a bug. o.a.m.p should not appear if org does. Should I
add some debug logging to help troubleshoot it, or did you want to step through in a debugger?
I don't see it here.
>> 
>> Adding the logging statements sounds good.  At least from the commits
>> I'll see what area of the code to look at if I can get it running in a
>> debugger, but I haven't done that in ages...
> 
> Will do.

... and done. You should turn org.apache.maven.archiva.web.action.BrowseAction up to debug.
You might get additional useful information from turning org.apache.archiva.metadata.repository
up to debug as well.

Try it at first with the existing ~/.archiva-metadata directory in place, then try deleting
it and see if it helps.


> 
>> 
>>> Thanks for giving it a spin!
>> 
>> I'm using it on my laptop for all builds.  Is there anything in
>> particular you want tested?
> 
> 
> Browsing and reporting were most affected. Detection of deletions on the filesystem are
known not to work (next on my list) - other than that it should be fine except that the location
of the metadata is not final.
> 
> Any testing will be helpful, though I'm also particularly interested in comments on the
architectural changes to see if others are happy going in that direction. I think I need to
write it up in a more condensed form :)
> 
> Cheers,
> Brett
> 
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> 
> 
> 
> 

--
Brett Porter
brett@apache.org
http://brettporter.wordpress.com/





Mime
View raw message