archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: [jira] Commented: (MRM-1252) Changing the repository indentifier breaks the entire repository index
Date Fri, 18 Sep 2009 00:32:42 GMT
Thanks, I posted your comments to the issue.

- Brett

On 18/09/2009, at 6:07 AM, Soumen Trivedi wrote:

> I used the following link (as I was upgrading from 1.1.x to 1.2.2)
>
> http://archiva.apache.org/docs/1.2.2/adminguide/upgrade.html
>
> You can find the commands to remove and reconfigure the indexing for
> repositories.
>
>
> Alternatively, another useful link for new installations is
> http://archiva.apache.org/docs/1.2.2/adminguide/installing.html
>
>
> On Thu, Sep 17, 2009 at 8:56 PM, Guntas (JIRA) <jira@codehaus.org>  
> wrote:
>
>>
>>   [
>> http://jira.codehaus.org/browse/MRM-1252?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=191376#action_191376]
>>
>> Guntas commented on MRM-1252:
>> -----------------------------
>>
>> Please point me to the instructions on deleting the index. I am  
>> sorry, but
>> could not find that on the Archiva site.
>>
>> Thanks for helping.
>>
>>> Changing the repository indentifier breaks the entire repository  
>>> index
>>> ----------------------------------------------------------------------
>>>
>>>                Key: MRM-1252
>>>                URL: http://jira.codehaus.org/browse/MRM-1252
>>>            Project: Archiva
>>>         Issue Type: Bug
>>>         Components: indexing, repository converter, repository  
>>> scanning
>>>   Affects Versions: 1.2.1
>>>        Environment: Solaris x86
>>>           Reporter: Guntas
>>>           Priority: Critical
>>>
>>> Hi,
>>> We moved the entire repository from one machine to another.  
>>> Earlier the
>> repository was managed by Archiva 1.2.1 with repository identifier as
>> 'Identifier1'. Now we have moved to a different machine and so we  
>> copied the
>> whole repository to the new machine and set up and configured new  
>> Archiva
>> with the repository identifier as 'Identifier2' (different from  
>> what it was
>> earlier). But pointing to the same old copied repository.
>>> Here the problem:
>>> Archiva is unable to search the artifact. And in the logs it says:
>>> ./logs/archiva.log:1585:2009-09-16 04:37:06,919 [btpool0-8] WARN
>> org.apache.archiva.indexer.search.NexusRepositorySearch  - Error  
>> accessing
>> index of repository 'Identifier2' : The existing index is for  
>> repository
>> [Identifier1] and not for repository [Identifier2]
>>> Could you please help me know that is by default Archiva storing the
>> index in the repository !! How can I fix this problem now?
>>> Thanks in advance.
>>
>> --
>> This message is automatically generated by JIRA.
>> -
>> If you think it was sent incorrectly contact one of the  
>> administrators:
>> http://jira.codehaus.org/secure/Administrators.jspa
>> -
>> For more information on JIRA, see: http://www.atlassian.com/software/jira
>>
>>
>>
>
>
> -- 
> Thanks & Regards,
> Soumen Trivedi
> +44 (0) 751 544 6779
> Email: Soumen.Trivedi@gmail.com


Mime
View raw message