archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nicolas de loof <nicolas.del...@gmail.com>
Subject Re: [VOTE] Release Archiva 1.2
Date Tue, 24 Mar 2009 10:49:34 GMT
This is fully repeatable, and the app is deployed on a private test context
path, so no request is coming in yet.

On Tue, Mar 24, 2009 at 11:45 AM, Brett Porter <brett@apache.org> wrote:

> Is this one repeatable? It might be that the app is getting hit at the same
> time as it is trying to migrate the roles on startup and we need to put some
> sync in place.
>
> - Brett
>
>
> On 24/03/2009, at 8:22 PM, nicolas de loof wrote:
>
>  The ClassNotFoundException are related to plexus roles,
>> the ConcurrentModificationException may be the real cause of my startup
>> failure, but it is related to redback :
>>
>> Caused by: java.util.ConcurrentModificationException
>> at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
>> at java.util.AbstractList$Itr.next(Unknown Source)
>> at
>>
>> org.codehaus.plexus.redback.role.processor.DefaultRoleModelProcessor.processRoles(DefaultRoleModelProcessor.java:218)
>> at
>>
>> org.codehaus.plexus.redback.role.processor.DefaultRoleModelProcessor.process(DefaultRoleModelProcessor.java:64)
>> at
>>
>> org.codehaus.plexus.redback.role.DefaultRoleManager.loadApplication(DefaultRoleManager.java:165)
>> at
>>
>> org.codehaus.plexus.redback.role.DefaultRoleManager.loadRoleModel(DefaultRoleManager.java:107)
>> at
>>
>> org.codehaus.plexus.redback.role.DefaultRoleManager.initialize(DefaultRoleManager.java:411)
>> at
>>
>> org.codehaus.plexus.spring.PlexusLifecycleBeanPostProcessor.postProcessAfterInitialization(PlexusLifecycleBeanPostProcessor.java:217)
>>
>> On Tue, Mar 24, 2009 at 9:30 AM, nicolas de loof
>> <nicolas.deloof@gmail.com>wrote:
>>
>>  Got some more infos on my startup error  :
>>>
>>> org.springframework.beans.factory.BeanCreationException: Error creating
>>> bean with name 'modelResolver': Initialization of bean failed;
>>> ...
>>> Caused by: java.lang.ClassNotFoundException:
>>> org.apache.maven.project.ModelResolver
>>>
>>> Is ModelResolver supposed to be a maven-project class ?
>>>
>>> I also get :
>>> ClassNotFoundException:
>>> org.apache.maven.artifact.repository.metadata.RepositoryMetadataBuilder
>>>
>>>
>>>
>>> I also notice some concurrency errors after this one :
>>>
>>> Caused by: java.util.ConcurrentModificationException
>>> at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
>>> at java.util.AbstractList$Itr.next(Unknown Source)
>>> at
>>>
>>> org.codehaus.plexus.redback.role.processor.DefaultRoleModelProcessor.processRoles(DefaultRoleModelProcessor.java:218)
>>>
>>> On Tue, Mar 24, 2009 at 9:07 AM, nicolas de loof <
>>> nicolas.deloof@gmail.com
>>>
>>>> wrote:
>>>>
>>>
>>>  I changed the log4j.xml to use a ConsoleAppender and everything in TRACE
>>>> I now have a 20Mo log and still no running archiva, but this strange
>>>> stacktrace that could explain no log with "standard" setting :
>>>>
>>>> log4j:ERROR Error occured while converting date.
>>>> java.lang.NullPointerException
>>>> at java.lang.System.arraycopy(Native Method)
>>>> at java.lang.AbstractStringBuilder.getChars(Unknown Source)
>>>> at java.lang.StringBuffer.getChars(Unknown Source)
>>>> at
>>>>
>>>> org.apache.log4j.helpers.AbsoluteTimeDateFormat.format(AbsoluteTimeDateFormat.java:117)
>>>> at java.text.DateFormat.format(Unknown Source)
>>>> at
>>>>
>>>> org.apache.log4j.helpers.PatternParser$DatePatternConverter.convert(PatternParser.java:444)
>>>> at
>>>>
>>>> org.apache.log4j.helpers.PatternConverter.format(PatternConverter.java:64)
>>>> at org.apache.log4j.PatternLayout.format(PatternLayout.java:503)
>>>> at org.apache.log4j.WriterAppender.subAppend(WriterAppender.java:301)
>>>> at org.apache.log4j.WriterAppender.append(WriterAppender.java:159)
>>>> at org.apache.log4j.AppenderSkeleton.doAppend(AppenderSkeleton.java:230)
>>>> at
>>>>
>>>> org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(AppenderAttachableImpl.java:65)
>>>> at org.apache.log4j.Category.callAppenders(Category.java:203)
>>>> at org.apache.log4j.Category.forcedLog(Category.java:388)
>>>> at org.apache.log4j.Category.log(Category.java:853)
>>>> at org.slf4j.impl.Log4jLoggerAdapter.log(Log4jLoggerAdapter.java:509)
>>>> at
>>>>
>>>> org.apache.commons.logging.impl.SLF4JLocationAwareLog.debug(SLF4JLocationAwareLog.java:106)
>>>>
>>>>
>>>>
>>>> On Tue, Mar 24, 2009 at 8:52 AM, Maria Odea Ching <oching@apache.org
>>>> >wrote:
>>>>
>>>>  It turns out I indeed forgot to set the appserver properties again
>>>>> yesterday, I was using a different console from where I've set the env
>>>>> so
>>>>> it
>>>>> didn't get set. I tried it again today, and I was able to access the
>>>>> Archiva
>>>>> webapp now (thanks Brett!) :) Maybe you did the same Nicolas?
>>>>>
>>>>> Anyway, here's my +1 for 1.2..
>>>>>
>>>>> -Deng
>>>>>
>>>>> On Tue, Mar 24, 2009 at 7:29 AM, Brett Porter <brett@apache.org>
>>>>> wrote:
>>>>>
>>>>>  Have you set the properties for the appserver[.base|.home] and added
>>>>>>
>>>>> mail
>>>>>
>>>>>> and activation into the Tomcat install?
>>>>>>
>>>>>> It sounds to me like this is still the same situation as in 1.1 by
the
>>>>>>
>>>>> bugs
>>>>>
>>>>>> that were filed, so we can continue with the release (once there
are
>>>>>>
>>>>> votes),
>>>>>
>>>>>> and I'd be happy to sit down later this week and remove all vestige
of
>>>>>>
>>>>> those
>>>>>
>>>>>> system properties for a quick 1.2.1.
>>>>>>
>>>>>> Cheers,
>>>>>> Brett
>>>>>>
>>>>>> On 24/03/2009, at 4:24 AM, Maria Odea Ching wrote:
>>>>>>
>>>>>> The log errors went away during startup but now I get a 404 when
I
>>>>>>
>>>>> access
>>>>>
>>>>>> the webapp. I'm now getting the same problem as Nicolas :( I wonder
if
>>>>>>>
>>>>>> it
>>>>>
>>>>>> is
>>>>>>> indeed related to the logs.. because I was able to access Archiva
>>>>>>> when
>>>>>>>
>>>>>> I
>>>>>
>>>>>> was
>>>>>>> having the log errors during startup and now that the logs dir
are
>>>>>>> properly
>>>>>>> set, I can no longer access the webapp and get a 404 instead.
>>>>>>>
>>>>>>> -Deng
>>>>>>>
>>>>>>>
>>>>>>>  --
>>>>>> Brett Porter
>>>>>> brett@apache.org
>>>>>> http://blogs.exist.com/bporter/
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>> Maria Odea Ching
>>>>> Software Engineer | Exist Global | 687-4091 | Skype: maria.odea.ching
|
>>>>> www.exist.com | Innovation Delivered
>>>>>
>>>>>
>>>>
>>>>
>>>
> --
> Brett Porter
> brett@apache.org
> http://blogs.exist.com/bporter/
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message