archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nicolas de loof <nicolas.del...@gmail.com>
Subject Re: [VOTE] Release Archiva 1.2
Date Mon, 23 Mar 2009 12:43:00 GMT
Hey, the class is "NullKnownHostProvider", with singular "Host"

On Mon, Mar 23, 2009 at 1:39 PM, nicolas de loof
<nicolas.deloof@gmail.com>wrote:

> Trying to run archiva 1.2 on my local dev Tomcat is better as I get console
> logs, but not really fine :
> ClassNotFoundException: org.apache.maven.project.ModelResolver
> ...
> Related cause:
> ClassNotFoundException:
> org.apache.maven.wagon.providers.ssh.knownhost.NullKnownHostsProvider
>
> (but wagon-ssh-common is in WEB-NF/lib ???)
>
>
>
>
>
> On Mon, Mar 23, 2009 at 12:51 PM, Brett Porter <brett@apache.org> wrote:
>
>> I had to step into the app with a debugger unfortunately to find the below
>> - do you have all of these set?
>>
>> - Brett
>>
>>
>> On 23/03/2009, at 10:36 PM, nicolas de loof wrote:
>>
>>  Right, I have changed the log4j.xml to use hard-coded path and set all
>>> loggers to "debug", but still fail starting Archiva and have no log in
>>> archiva.log :'(
>>>
>>> Seems to be the "something went wrong, let's see if you can guess the
>>> exception" case :)
>>>
>>>
>>> On Mon, Mar 23, 2009 at 12:27 PM, Brett Porter <brett@apache.org> wrote:
>>>
>>>
>>>> On 23/03/2009, at 10:15 PM, nicolas de loof wrote:
>>>>
>>>> Did I miss something or was this allready required in 1.1.* ?
>>>>
>>>>> I can't remember having patched the standard war but it woks fine on
my
>>>>> tomcat. Beeing a shared instance I can't setup custom JVM system
>>>>> properties
>>>>> :(
>>>>>
>>>>>
>>>> It was, but only for logs.
>>>>
>>>> http://archiva.apache.org/docs/1.1.3/adminguide/webapp.html
>>>>
>>>> All of the following are required (the JSW startup scripts set them in
>>>> standalone):
>>>>
>>>> * appserver.base set
>>>> * appserver.home set
>>>> * activation.jar and mail.jar in tomcat's common/lib
>>>>
>>>> I've wanted to remove this for a while, but it fell off my radar... I'll
>>>> see if there's a way to set it elsewhere than the command line.
>>>>
>>>> - Brett
>>>>
>>>>
>>>> --
>>>> Brett Porter
>>>> brett@apache.org
>>>> http://blogs.exist.com/bporter/
>>>>
>>>>
>>>>
>> --
>> Brett Porter
>> brett@apache.org
>> http://blogs.exist.com/bporter/
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message