archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James William Dumay <ja...@atlassian.com>
Subject Re: [VOTE] Release Archiva 1.2
Date Wed, 25 Mar 2009 02:41:56 GMT
-1

I know it is a little late in the process, but I want to vote against 
releasing 1.2.

MRM-1154 blocks all users of Maven 2.1.x from using Archiva since our 
metadata merging barfs on the xml schema attributes that were slipped 
into the 2.1.x format.

It might also be wise for us to ship a 1.1.4 release that allows 
compatibility for those who are sticking to the current stable release 
event after 1.2 is GA.

Thoughts?

James

nicolas de loof wrote:
> After javamail update I get it to work, and I also get logs in archiva.log
> :D
> So as a summary
> - on tomcat 5.5 javamail>  1.2 seems to be required,
> - migration from a 1.1 user database is broken
> - some bad component.xml metadata are repported by the spring-plexus bridge
>
> The 2nd one is a restriction that must be documented in the release note as
> this is not easy to know what's wrong when the app didn't start.
>
> As I really have fiew time to test the release, and even less to contribute,
> here is my +0
>
> On Tue, Mar 24, 2009 at 2:02 PM, nicolas de loof
> <nicolas.deloof@gmail.com>wrote:
>
>    
>> My tomcat has mail.jar 1.2 in common/libbut this version allready defines
>> a public InternetAddress( String ) AFAIK.
>>
>>
>> On Tue, Mar 24, 2009 at 12:33 PM, Brett Porter<brett@apache.org>  wrote:
>>
>>      
>>> I'm using 1.4.
>>>
>>>
>>> On 24/03/2009, at 10:25 PM, nicolas de loof wrote:
>>>
>>>   Archiva starts with a fresh new user database.
>>>        
>>>> But I can't create the admin :
>>>> java.lang.IllegalAccessError: tried to access method
>>>> javax.mail.internet.InternetAddress.<init>(Ljava/lang/String;Z)
>>>>
>>>> Seems my tomcat instance doesn't have the expected javamail version
>>>>
>>>>
>>>> On Tue, Mar 24, 2009 at 12:18 PM, nicolas de loof
>>>> <nicolas.deloof@gmail.com>wrote:
>>>>
>>>>   java.lang.OutOfMemoryError: PermGen space :-/
>>>>          
>>>>> Seems i've made too much start/stop tests - This time I will need some
>>>>> help
>>>>> from my system admin :)
>>>>>
>>>>> On Tue, Mar 24, 2009 at 12:10 PM, Brett Porter<brett@apache.org>
>>>>> wrote:
>>>>>
>>>>>   Are you able to check if it works with a clean one? I did try the
>>>>>            
>>>>>> upgrade
>>>>>> earlier, but I wonder if anyone else is testing an upgrade from an
>>>>>> older
>>>>>> version?
>>>>>>
>>>>>> - Brett
>>>>>>
>>>>>>
>>>>>> On 24/03/2009, at 10:04 PM, nicolas de loof wrote:
>>>>>>
>>>>>> I'm sharing the database from my existing Archiva 1.1.1 instance
>>>>>>
>>>>>>              
>>>>>>> On Tue, Mar 24, 2009 at 12:03 PM, Brett Porter<brett@apache.org>
>>>>>>> wrote:
>>>>>>>
>>>>>>> On 24/03/2009, at 9:49 PM, nicolas de loof wrote:
>>>>>>>
>>>>>>>                
>>>>>>>> This is fully repeatable, and the app is deployed on a private
test
>>>>>>>>
>>>>>>>>   context
>>>>>>>>                  
>>>>>>>>> path, so no request is coming in yet.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>   Does the test set up have an existing users database
or a clean
>>>>>>>>>                    
>>>>>>>> users
>>>>>>>> database?
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Brett
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> Brett Porter
>>>>>>>> brett@apache.org
>>>>>>>> http://blogs.exist.com/bporter/
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>   --
>>>>>>>>                  
>>>>>> Brett Porter
>>>>>> brett@apache.org
>>>>>> http://blogs.exist.com/bporter/
>>>>>>
>>>>>>
>>>>>>
>>>>>>              
>>> --
>>> Brett Porter
>>> brett@apache.org
>>> http://blogs.exist.com/bporter/
>>>
>>>
>>>        
>
>    

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message