archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maria Odea Ching <och...@apache.org>
Subject Re: [VOTE] Release Archiva 1.2
Date Mon, 23 Mar 2009 16:50:46 GMT
The logs dir already exists in [TOMCAT_INSTALLATION]/logs. That was where I
pointed the archiva logs in log4j.xml but when I started up the server, it
was still looking in the /logs dir and not in [TOMCAT_INSTALLATION]/logs
where I pointed it to..

-Deng

On Tue, Mar 24, 2009 at 12:36 AM, Emmanuel Venisse <
emmanuel.venisse@gmail.com> wrote:

> The logs directory isn't created automatically, so you must create it
> first.I
> don't think it is good to use "/logs", /var/tomcat/logs or something else
> would be better
>
> Emmanuel
>
> On Mon, Mar 23, 2009 at 5:14 PM, Maria Odea Ching <oching@apache.org>
> wrote:
>
> > I was able to deploy and access the archiva 1.2 war in tomcat 5.5.17
> > (ubuntu
> > linux)
> > I had the following error during startup though (even after I edited the
> > log4j.xml file in the war to set the path to the logs):
> >
> > log4j:ERROR setFile(null,true) call failed.
> > java.io.FileNotFoundException: /logs/archiva-security-audit.log (No such
> > file or directory)
> >        at java.io.FileOutputStream.openAppend(Native Method)
> >        at java.io.FileOutputStream.<init>(FileOutputStream.java:177)
> >        at java.io.FileOutputStream.<init>(FileOutputStream.java:102)
> >        at org.apache.log4j.FileAppender.setFile(FileAppender.java:289)
> >        at
> > org.apache.log4j.FileAppender.activateOptions(FileAppender.java:163)
> >        at
> >
> >
> org.apache.log4j.DailyRollingFileAppender.activateOptions(DailyRollingFileAppender.java:215)
> >        at
> > org.apache.log4j.config.PropertySetter.activate(PropertySetter.java:256)
> >        at
> >
> >
> org.apache.log4j.xml.DOMConfigurator.parseAppender(DOMConfigurator.java:220)
> > ...
> > log4j:ERROR Either File or DatePattern options are not set for appender
> > [redbackAuditLog].
> > log4j:ERROR setFile(null,true) call failed.
> > java.io.FileNotFoundException: /logs/archiva.log (No such file or
> > directory)
> >        at java.io.FileOutputStream.openAppend(Native Method)
> >        at java.io.FileOutputStream.<init>(FileOutputStream.java:177)
> >        at java.io.FileOutputStream.<init>(FileOutputStream.java:102)
> >        at org.apache.log4j.FileAppender.setFile(FileAppender.java:289)
> >        at
> > org.apache.log4j.FileAppender.activateOptions(FileAppender.java:163)
> >        at
> >
> >
> org.apache.log4j.DailyRollingFileAppender.activateOptions(DailyRollingFileAppender.java:215)
> > ...
> >
> > I was still able to access Archiva webapp even with the above errors..
> > Could the problem you encountered be related to
> > http://jira.codehaus.org/browse/MRM-1085 ?
> >
> > Thanks,
> > Deng
> >
> > On Mon, Mar 23, 2009 at 11:25 PM, Maria Odea Ching <oching@apache.org
> > >wrote:
> >
> > > I'll try deploying the war on my end as well and see if i can get
> > anything
> > > out from the logs..
> > >
> > > -Deng
> > >
> > >
> > > On Mon, Mar 23, 2009 at 9:01 PM, nicolas de loof <
> > nicolas.deloof@gmail.com
> > > > wrote:
> > >
> > >> Works far better on my dev environment with wagon-ssh component.xml
> > fixed
> > >> ;)
> > >>
> > >> But still not starts / no log on my target server, that I can't remote
> > >> debug
> > >> :'(
> > >>
> > >> On Mon, Mar 23, 2009 at 1:43 PM, nicolas de loof
> > >> <nicolas.deloof@gmail.com>wrote:
> > >>
> > >> > Hey, the class is "NullKnownHostProvider", with singular "Host"
> > >> >
> > >> >
> > >> > On Mon, Mar 23, 2009 at 1:39 PM, nicolas de loof <
> > >> nicolas.deloof@gmail.com
> > >> > > wrote:
> > >> >
> > >> >> Trying to run archiva 1.2 on my local dev Tomcat is better as
I get
> > >> >> console logs, but not really fine :
> > >> >> ClassNotFoundException: org.apache.maven.project.ModelResolver
> > >> >> ...
> > >> >> Related cause:
> > >> >> ClassNotFoundException:
> > >> >>
> org.apache.maven.wagon.providers.ssh.knownhost.NullKnownHostsProvider
> > >> >>
> > >> >> (but wagon-ssh-common is in WEB-NF/lib ???)
> > >> >>
> > >> >>
> > >> >>
> > >> >>
> > >> >>
> > >> >> On Mon, Mar 23, 2009 at 12:51 PM, Brett Porter <brett@apache.org>
> > >> wrote:
> > >> >>
> > >> >>> I had to step into the app with a debugger unfortunately to
find
> the
> > >> >>> below - do you have all of these set?
> > >> >>>
> > >> >>> - Brett
> > >> >>>
> > >> >>>
> > >> >>> On 23/03/2009, at 10:36 PM, nicolas de loof wrote:
> > >> >>>
> > >> >>>  Right, I have changed the log4j.xml to use hard-coded path
and
> set
> > >> all
> > >> >>>> loggers to "debug", but still fail starting Archiva and
have no
> log
> > >> in
> > >> >>>> archiva.log :'(
> > >> >>>>
> > >> >>>> Seems to be the "something went wrong, let's see if you
can guess
> > the
> > >> >>>> exception" case :)
> > >> >>>>
> > >> >>>>
> > >> >>>> On Mon, Mar 23, 2009 at 12:27 PM, Brett Porter <brett@apache.org
> >
> > >> >>>> wrote:
> > >> >>>>
> > >> >>>>
> > >> >>>>> On 23/03/2009, at 10:15 PM, nicolas de loof wrote:
> > >> >>>>>
> > >> >>>>> Did I miss something or was this allready required
in 1.1.* ?
> > >> >>>>>
> > >> >>>>>> I can't remember having patched the standard war
but it woks
> fine
> > >> on
> > >> >>>>>> my
> > >> >>>>>> tomcat. Beeing a shared instance I can't setup
custom JVM
> system
> > >> >>>>>> properties
> > >> >>>>>> :(
> > >> >>>>>>
> > >> >>>>>>
> > >> >>>>> It was, but only for logs.
> > >> >>>>>
> > >> >>>>> http://archiva.apache.org/docs/1.1.3/adminguide/webapp.html
> > >> >>>>>
> > >> >>>>> All of the following are required (the JSW startup
scripts set
> > them
> > >> in
> > >> >>>>> standalone):
> > >> >>>>>
> > >> >>>>> * appserver.base set
> > >> >>>>> * appserver.home set
> > >> >>>>> * activation.jar and mail.jar in tomcat's common/lib
> > >> >>>>>
> > >> >>>>> I've wanted to remove this for a while, but it fell
off my
> > radar...
> > >> >>>>> I'll
> > >> >>>>> see if there's a way to set it elsewhere than the
command line.
> > >> >>>>>
> > >> >>>>> - Brett
> > >> >>>>>
> > >> >>>>>
> > >> >>>>> --
> > >> >>>>> Brett Porter
> > >> >>>>> brett@apache.org
> > >> >>>>> http://blogs.exist.com/bporter/
> > >> >>>>>
> > >> >>>>>
> > >> >>>>>
> > >> >>> --
> > >> >>> Brett Porter
> > >> >>> brett@apache.org
> > >> >>> http://blogs.exist.com/bporter/
> > >> >>>
> > >> >>>
> > >> >>
> > >> >
> > >>
> > >
> > >
> > >
> > > --
> > > Maria Odea Ching
> > > Software Engineer | Exist Global | 687-4091 | Skype: maria.odea.ching |
> > > www.exist.com | Innovation Delivered
> > >
> >
> >
> >
> > --
> > Maria Odea Ching
> > Software Engineer | Exist Global | 687-4091 | Skype: maria.odea.ching |
> > www.exist.com | Innovation Delivered
> >
>



-- 
Maria Odea Ching
Software Engineer | Exist Global | 687-4091 | Skype: maria.odea.ching |
www.exist.com | Innovation Delivered

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message