archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Cooper" <mart...@apache.org>
Subject Re: Anyone using IntelliJ IDEA?
Date Wed, 26 Nov 2008 06:29:46 GMT
On Tue, Nov 25, 2008 at 3:11 PM, James William Dumay <james@atlassian.com>wrote:

> On Tue, 2008-11-25 at 16:05 +1100, Brett Porter wrote:
> > I haven't for a while, and when I did I still used jetty:run (though
> > on trunk this has some other problems since the migration to struts2)
>
> No big problems - you just need to run jetty:run-war.


Run it from where? If I run it from archiva-jetty, it can't find the war
file. If I run it from archiva-webapp, I get the following:


2008-11-25 21:26:56.890::WARN:  Configuration problem at <resource-ref>
                <res-ref-name>jdbc/users</res-ref-name>
                <res-type>javax.sql.DataSource</res-type>
                <res-auth>Container</res-auth>
                <res-sharing-scope>Shareable</res-sharing-scope>
        </resource-ref>
javax.naming.NameNotFoundException: No resource to bind matching
name=jdbc/users


I'd be more than happy to write up a wiki page on how to get going with
Archiva development once I've sorted all this out. Right now, though, I'm
finding it *very* frustrating, perhaps because there appears to be a good
deal of shared knowledge of how it all works, but that knowledge is not
available to newcomers because it is simply not documented.

--
Martin Cooper


James
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message