archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James William Dumay <ja...@atlassian.com>
Subject Re: Release 1.1.2?
Date Wed, 10 Sep 2008 10:09:54 GMT
Hey deng,
The release looks great to go :)

Thanks again for getting all those bug fixes in!

James



On 10/09/2008, at 7:09 PM, "Maria Odea Ching" <oching@apache.org> wrote:

> Hi Everyone,
>
> I'd like to prepare the release for 1.1.2 this week. For this  
> release, the
> following issues have already been resolved:
>
>    * [MRM-765] - should not be possible to create a proxy connector if
> there are no remote repositories
>    * [MRM-807] - Deployed dll won't be indexed
>    * [MRM-841] - Introducing a new scannable artifact file type  
> requires
> restart in order for some consumers to work
>    * [MRM-880] - Archiva does not start up on Solaris 64-Bit
>    * [MRM-881] - Failing to startup due to invalid bean definition
>    * [MRM-893] - Illegal browse operation allow
>    * [MRM-902] - If path has leading slash when being checked againts
> whitelists and blacklists causes matching failure
>    * [MRM-903] - Repository scanning should not stop when encounters  
> error
>    * [MRM-905] - EL Expression failed with empty/not functions
>    * [MRM-911] - Archiva checks user's credentials before guest's  
> rights on
> the repository
>    * [MRM-915] - NPE with rss links
>    * [MRM-926] - NPE with search page
>    * [MRM-932] - Error 500 when clicking the Next or Previous icon  
> of the
> results of a search, if user is trying to search for java classes,  
> packages
> or methods.
>    * [MRM-934] - For bytecode search, only 1 version of the artifact  
> is
> returned even if there are more than 1 version of that artifact which
> matched the search
>    * [MRM-839] - change RSS URLs
>    * [MRM-848] - Pre-configured repositories initially appear to be  
> empty
>    * [MRM-874] - POM snippet for plugins should be <plugin> not
> <dependency>
>
> And there is only one remaining issue open:
>
>    * [MRM-909] - Direct connect proxy setting is ignored after  
> undetermined
> event
>
> I'll take a look at MRM-909 tomorrow and see if I could replicate this
> problem (as it occurs at indefinite times). If I couldn't replicate  
> this
> issue by tomorrow, I'll move it to the next release for further
> investigation :)
>
> Comments? Thoughts?
>
>
> Thanks,
> Deng

Mime
View raw message