archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James William Dumay <ja...@atlassian.com>
Subject Re: Release 1.1.2?
Date Fri, 12 Sep 2008 00:19:57 GMT
Hey Andrew,

On Thu, 2008-09-11 at 11:39 +0100, Andrew Heald wrote:
> Hi All,
> 
> I've now had an excellent experience of 1.1.1 on my Linux environment.
> Great! I'm looking forward to 1.1.2.
> 
> I've had difficulties at a client site were Archiva performance on Windows
> Server has been dogged by the issue in
> http://jira.codehaus.org/browse/MRM-243. I still have 1.0.2 installed
> there and I'm still deploying to a mod_dav managed repo and using Archiva
> only as a proxy to that. I'd like to return to deploying directly to
> Archiva.
> 
> I'm not entirely aware of what has changed, if anything, in the area of
> webdav deployment in Archiva. Is it likely that I'll see a resolution to
> the problems because there's been significant work in that area?
> 

The webdav layer was completely ripped out and replaced for Archiva 1.1.
Having worked on this I can assure you that you won't see this issue
crop up in 1.1 or later.

> I'm aware that I might well be labouring a point here. I need to do this
> because the client is extremely sensitive to build failures caused by this
> sort of thing.
> 
> While I'm at it I must also comment on
> http://jira.codehaus.org/browse/MRM-834. Brett's patch works perfectly for
> me and I'd like to see it, or something like it, go mainstream.

Ill make this one of my priorities to get MRM-834 into the next major
release (in this case 1.2).

Thanks for giving us feedback Andrew!

James

> 
> Thanks,
> Andrew.
> 
> On Wed, September 10, 2008 10:09 am, Maria Odea Ching wrote:
> > Hi Everyone,
> >
> > I'd like to prepare the release for 1.1.2 this week. For this release, the
> > following issues have already been resolved:
> >
> >     * [MRM-765] - should not be possible to create a proxy connector if
> > there are no remote repositories
> >     * [MRM-807] - Deployed dll won't be indexed
> >     * [MRM-841] - Introducing a new scannable artifact file type requires
> > restart in order for some consumers to work
> >     * [MRM-880] - Archiva does not start up on Solaris 64-Bit
> >     * [MRM-881] - Failing to startup due to invalid bean definition
> >     * [MRM-893] - Illegal browse operation allow
> >     * [MRM-902] - If path has leading slash when being checked againts
> > whitelists and blacklists causes matching failure
> >     * [MRM-903] - Repository scanning should not stop when encounters
> > error
> >     * [MRM-905] - EL Expression failed with empty/not functions
> >     * [MRM-911] - Archiva checks user's credentials before guest's rights
> > on
> > the repository
> >     * [MRM-915] - NPE with rss links
> >     * [MRM-926] - NPE with search page
> >     * [MRM-932] - Error 500 when clicking the Next or Previous icon of the
> > results of a search, if user is trying to search for java classes,
> > packages
> > or methods.
> >     * [MRM-934] - For bytecode search, only 1 version of the artifact is
> > returned even if there are more than 1 version of that artifact which
> > matched the search
> >     * [MRM-839] - change RSS URLs
> >     * [MRM-848] - Pre-configured repositories initially appear to be empty
> >     * [MRM-874] - POM snippet for plugins should be <plugin> not
> > <dependency>
> >
> > And there is only one remaining issue open:
> >
> >     * [MRM-909] - Direct connect proxy setting is ignored after
> > undetermined
> > event
> >
> > I'll take a look at MRM-909 tomorrow and see if I could replicate this
> > problem (as it occurs at indefinite times). If I couldn't replicate this
> > issue by tomorrow, I'll move it to the next release for further
> > investigation :)
> >
> > Comments? Thoughts?
> >
> >
> > Thanks,
> > Deng
> >
> 
> 


Mime
View raw message