archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Question about Usage or Bug
Date Fri, 21 Mar 2008 08:48:44 GMT
Is there anything else in the logs, or a message passed in the URL?

On 21/03/2008, at 2:39 AM, Simmons, Robert wrote:

> Greetings,
>
> I use Archiva running in tomcat (latest stable) and I was wondering
> about a problem I am having. I was able to add a user to archiva for  
> the
> purposes of using the repository. The user is a Global Repository
> Manager as well as Global Repository Observer. In addition I have  
> tried
> giving them the manager and observer roles on all three repositories  
> we
> have set up (thirdparty, internal and internal-snapshots). The user is
> also tagged with "Registered User" and not withGuest (though I have
> tried that).
>
> The problem is that the user can deploy artifacts and everything is
> peachy but when they attempt to log in through the Archiva UI to  
> browse
> the repository or search, they get the error that the login name or
> password is incorrect. Ther actual login information has been  
> validated
> many times and the user is not locked.
>
> What I want to do is give my users the ability to log in to search and
> browse but not manage repositories in the administrative sense. How  
> do I
> go about doing this?
>
> Thanks for your time.
>
> Robert Simmons Jr
> Senior Software Engineer
> ICAT Managers LLC <http://www.icat.com/>
> W: +1 (303) 447-1155 x2431
> M: +1 (720) 346-3868
>

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


Mime
View raw message