archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Trunk has a build loop??
Date Mon, 17 Mar 2008 03:53:38 GMT
On 17/03/2008, at 2:05 PM, Wendy Smoak wrote:

> On Sun, Mar 16, 2008 at 7:13 PM, Maria Odea Ching  
> <oching@apache.org> wrote:
>> Hmm, the jetty bundle should be working.. it already worked for me  
>> before. I
>> tried it again today and was able to start it. I'm running on Linux  
>> btw.
>>
>> Wendy, did you get the 'Starting Archiva Web ::  Jetty...' message  
>> when you
>> did './archiva start'?
>
> Yes, but that's the only thing that happened  (it printed the message,
> but didn't actually start.)  I've been having other problems though,
> it's probably related to that.  At least jetty:run is now working in
> Continuum.  I'll come back around to Archiva at some point and
> re-check.


For me, the plexus runtime works. There seems to be a bug triggered in  
the Jetty runtime which is two-fold. plexus-webdav is still dragged in  
(my fault, I'll look it up).

But I also noticed a bug in the assembly descriptor too - did anyone  
noticed archiva jetty bakes a 53Mb ZIP file? :) It seems everything is  
included in repo/*, when really we just want the Jetty JARs.

- Brett

--
Brett Porter
brett@apache.org
http://blogs.exist.com/bporter/


Mime
View raw message