archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Trouble with 'mvn site' for archiva/trunk
Date Sun, 30 Dec 2007 19:06:16 GMT
I'm having trouble running 'mvn site' from archiva/trunk.  (Also from
the archvia-1.0 tag, where I was attempting to publish the docs.)

INFO] [dependency:copy {execution: copy}]
[INFO] Configured Artifact:
org.apache.maven.archiva:archiva-applet:null:1.1-SNAPSHOT:jar
[INFO] archiva-applet-1.1-SNAPSHOT.jar already exists.
[INFO] [compiler:compile]
[INFO] Nothing to compile - all classes are up to date
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error configuring: org.apache.maven.plugins:maven-war-plugin.
Reason: ERROR: Cannot override read-only parameter: classesDirectory
in goal: war:inplace
[INFO] ------------------------------------------------------------------------

Here's the full log:
http://people.apache.org/~wsmoak/maven/archiva/mvn-site-20071230.txt

$ mvn -version
Maven version: 2.0.8
Java version: 1.5.0_13
OS name: "mac os x" version: "10.4.11" arch: "i386" Family: "unix"

I've tried it with war plugin versions 2.0 and 2.1-alpha-1 with the
same result (above).

With 2.1-alpha-2-SNAPSHOT, I get a NPE instead:

$ mvn site
...
[WARNING] DEPRECATED [dependentWarExcludes]: use the excludes in the
overlay object instead
[INFO] [war:inplace {execution: default}]
[INFO] Generating webapp in source
directory[/Users/wsmoak/svn/maven/archiva/archiva-web/archiva-webapp/src/main/webapp]
[INFO] Assembling webapp[archiva-webapp] in
[/Users/wsmoak/svn/maven/archiva/archiva-web/archiva-webapp/src/main/webapp]
[INFO] ------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO] ------------------------------------------------------------------------
[INFO] null
[INFO] ------------------------------------------------------------------------
[INFO] Trace
java.lang.NullPointerException
	at org.apache.maven.plugin.war.util.WebappStructure.getDependencies(WebappStructure.java:107)
	at org.apache.maven.plugin.war.util.WebappStructure.analyseDependencies(WebappStructure.java:286)
	at org.apache.maven.plugin.war.packaging.DependenciesAnalysisPackagingTask.performPackaging(DependenciesAnalysisPackagingTask.java:46)
	at org.apache.maven.plugin.war.AbstractWarMojo.buildWebapp(AbstractWarMojo.java:373)
...

The last time I know the site worked was back in October when I
published this:
http://maven.apache.org/archiva/ref/1.0-beta-3-SNAPSHOT/

Can someone else try it and let me know whether 'mvn site' works?

-- 
Wendy

Mime
View raw message