archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: archiva-backend-security branch.
Date Mon, 05 Nov 2007 03:36:08 GMT

On 05/11/2007, at 2:32 PM, Joakim Erdfelt wrote:

> There's nothing to present the "There are no repositories you have
> access to" style message on the xwork side.
> I should add that.

This doesn't seem to be the problem below though?

I haven't tried yet - was going to do so later today still.

>
> Also, the branch has the old embedded appserver.base antrun.
> If you have a $HOME/.m2/archiva.xml + that embedded appserver.base
> antrun, you'll have no repositories presented to you. nor any ability
> for them to startup in default mode.
>
> I understand the purpose of the embedded appserver.base antrun, but it
> doesn't work in practice, some other things need to be fixed first.
> Maybe we should disable the embedded appserver.base antrun until we  
> can
> solve all the use-cases properly.
>
> Brett suggested to me to specify the appserver.base on the command  
> line
> via the
> -Dappserver.base=alternative/dir/to/the/your/custom/appserver/base  
> but I
> never got that to work.

Like I said before, just put it in a profile until you figure out  
what's going on and I'll just enable the profile by default.

>
> - Joakim
>
> Maria Odea Ching wrote:
>> I've tried running the branch, but I got a 500 error when I clicked
>> Browse after doing a repo scan.. this was the cause of the error I  
>> got:
>>
>> java.lang.IllegalArgumentException: Selected repositories cannot be
>> null. at
>> org.apache.maven.archiva.database.constraints.SqlBuilder.appendWhereS 
>> electedRepositories(SqlBuilder.java:64)
>> at
>> org.apache.maven.archiva.database.constraints.UniqueGroupIdConstraint 
>> .(UniqueGroupIdConstraint.java:50)
>> at
>> org.apache.maven.archiva.database.browsing.DefaultRepositoryBrowsing. 
>> getRoot(DefaultRepositoryBrowsing.java:69)
>> at
>> org.apache.maven.archiva.web.action.BrowseAction.browse 
>> (BrowseAction.java:69)
>>
>>
>> Is it just me or did anybody get this too?
>>
>> I also noticed that there were no default remote repositories and
>> proxy connectors configured (both in trunk and branch). Is this the
>> new setup? (Btw, I used jetty:run to run the webapp) :)
>>
>> Thanks,
>> Deng
>>
>>
>> Joakim Erdfelt wrote:
>>> I'm wrapping up work on the archiva-backend-security branch.
>>> I'll need a review (or two) before I can merge this code back into
>>> trunk.
>>>
>>> Fixed Issues (in trunk):
>>> MRM-569 - Browse shows results for all repositories, regardless of
>>> security.
>>> MRM-516 - Search results return results for all repositories,
>>> regardless of security.
>>>
>>> Thanks,
>>>
>>
>

--
Brett Porter - brett@apache.org
Blog: http://www.devzuz.org/blogs/bporter/


Mime
View raw message