archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nicolas de loof" <nicolas.del...@gmail.com>
Subject Re: [VOTE] Release Archiva-1.0-beta-1
Date Tue, 07 Aug 2007 09:35:22 GMT
Without those configuration issues, you get my +1 for a beta.

the "repository/*" url works fine for both maven1 and maven2 requests.
The only feature I'm still missing is having archiva internally  handling
relocation for artifacts requested by maven1... maybe in beta-3 ?

I also notice the ProxiedDavServer "get" method still use hasResource() and
bypass fetching from propxies if present, so there's no way to get newer
snapshots. This may change with the separation between webdav and "GET"
urls.

Nico.



2007/8/7, nicolas de loof <nicolas.deloof@gmail.com>:
>
> MRM-460 created.
> The typo is only in CacheFailurePolicy log message.
> The main issue is about the archiva default config that refers to an
> invalid "cache" value.
>
>
> Abnother issue with the proposed beta : I had to edit wrapper.conf to set
>    wrapper.java.initmemory=8
> as I got (on windows, using run.bat) :
> jvm 1    | [ERROR] Specified initial heap size (3 MB) is less than the
> minimum required initial heap size (8 MB).
> jvm 1    | Could not create the Java virtual machine.
>
>
> 2007/8/7, Brett Porter <brett@apache.org>:
> >
> > Is this actually the checksum policy checker, or is it a typo in the
> > description too?
> >
> > Can you put this as a patch in jira? :)
> >
> > - Brett
> >
> > On 07/08/2007, at 6:55 PM, nicolas de loof wrote:
> >
> > > It seems to be a typo in CachedFailuresPolicy
> > >
> > > "
> > >     public boolean applyPolicy( String policySetting, Properties
> > > request,
> > > File localFile )
> > >     {
> > >         if ( !options.contains( policySetting ) )
> > >         {
> > >             // No valid code? false it is then.
> > >             getLogger().error( "Unknown checksum policyCode [" +
> > > policySetting + "]" );
> > >             return false;
> > >         }
> > > "
> > >
> > > That beeing said, the constant is set to "cached" and the default
> > > config to
> > > "cache".
> > > Editing the network-proxies and setting to "cached" solved this.
> > >
> > >
> > > 2007/8/7, nicolas de loof <nicolas.deloof@gmail.com>:
> > >>
> > >> I cannot get any artifact from proxy due to some strange checksum
> > >> policy
> > >> error :
> > >>
> > >> According to log, the proxied-repo is set to policy[checksum]:fix :
> > >>     ProxyConnector[
> > >>     jvm 1    |
> > >> source:ArchivaRepository[internal,file://D:\temp\.....data/
> > >> repositories/internal]
> > >>     jvm 1    |   target:ArchivaRepository[central,
> > >> http://repo1.maven.org/maven2]
> > >>     jvm 1    |   proxyId:
> > >>     jvm 1    |   policy[releases]:once
> > >>     jvm 1    |   policy[checksum]:fix
> > >>     jvm 1    |   policy[snapshots]:disabled
> > >>     jvm 1    |   policy[cache-failures]:cache
> > >>     jvm 1    | ]
> > >>
> > >> But latter, I get an Error about Unknown checksum policyCode [cache]
> > >>
> > >> jvm 1    | 2007-08-07 10:37:20,481 [SocketListener0-1] ERROR
> > >> org.apache.maven.archiva.policies.PreDownloadPolicy:cache-failures  -
> > >> Unknown checksum policyCode
> > >>
> > >>
> > >> I also had to delete my old $HOME/.m2/archiva.xml as I cannot make
> > >> any
> > >> change in the configuration "cannot save configuration when 2
> > >> sources are
> > >> used".
> > >> Is there any update guide to convert old-style configuration into
> > >> archiva
> > >> 1.0 ? If none, why does archiva still read this deprecated and
> > >> uneditable
> > >> archiva.xml file ?
> > >>
> > >> Nico.
> > >>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message