archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Use of JDK 5 in Archiva
Date Tue, 19 Jun 2007 01:31:06 GMT
As in Continuum, I've made this change. I'm going with lazy consensus  
- so if there are any objections please holler before dependent code  
arrives :)

On 19/06/2007, at 11:26 AM, brett@apache.org wrote:

> Author: brett
> Date: Mon Jun 18 18:26:34 2007
> New Revision: 548544
>
> URL: http://svn.apache.org/viewvc?view=rev&rev=548544
> Log:
> allow use of JDK 5 in Archiva
>
> Modified:
>     maven/archiva/trunk/pom.xml
>
> Modified: maven/archiva/trunk/pom.xml
> URL: http://svn.apache.org/viewvc/maven/archiva/trunk/pom.xml? 
> view=diff&rev=548544&r1=548543&r2=548544
> ====================================================================== 
> ========
> --- maven/archiva/trunk/pom.xml (original)
> +++ maven/archiva/trunk/pom.xml Mon Jun 18 18:26:34 2007
> @@ -95,11 +95,31 @@
>            </execution>
>          </executions>
>        </plugin>
> +<!-- Doesn't work on Mac with Java 6 yet
> +      <plugin>
> +        <artifactId>maven-enforcer-plugin</artifactId>
> +        <executions>
> +          <execution>
> +            <id>enforce-java</id>
> +            <goals>
> +              <goal>enforce-once</goal>
> +            </goals>
> +            <configuration>
> +              <rules>
> +                <requireJavaVersion>
> +                  <version>1.5.0</version>
> +                </requireJavaVersion>
> +              </rules>
> +            </configuration>
> +          </execution>
> +        </executions>
> +      </plugin>
> +-->
>        <plugin>
>          <artifactId>maven-compiler-plugin</artifactId>
>          <configuration>
> -          <source>1.4</source>
> -          <target>1.4</target>
> +          <source>1.5</source>
> +          <target>1.5</target>
>          </configuration>
>        </plugin>
>        <plugin>
>

Mime
View raw message