archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: Let's release Archiva
Date Thu, 12 Apr 2007 13:44:00 GMT
On 4/11/07, Wendy Smoak <wsmoak@gmail.com> wrote:

> [INFO] Can't release project due to non released dependencies :
>     org.codehaus.mojo:jpox-maven-plugin:maven-plugin:1.1.7-SNAPSHOT:runtime
> in project 'Archiva Standard Reports' (org.apache.maven.archiva:archiva-reports-
> standard:jar:1.0-SNAPSHOT)

Over on dev@mojo, Emmanuel  wrote that we don't really need 1.1.7,
that 1.1.6 would be fine.  Emmannuel, do I need to change both the
plugin version and the jpox version that is declared separately? (see
below)

It seems to only be used directly in the archiva-reports-standard
module.  Is there anywhere else it gets used that we should double
check for breakage?

Index: archiva-reports-standard/pom.xml
===================================================================
--- archiva-reports-standard/pom.xml    (revision 527765)
+++ archiva-reports-standard/pom.xml    (working copy)
@@ -95,7 +95,7 @@
     <dependency>
       <groupId>jpox</groupId>
       <artifactId>jpox</artifactId>
-      <version>1.1.7</version>
+      <version>1.1.6</version>        <------- ?
       <scope>compile</scope>
       <exclusions>
         <!-- targeting JDK 1.4 we don't need this -->
@@ -141,7 +141,7 @@
       <plugin>
        <groupId>org.codehaus.mojo</groupId>
         <artifactId>jpox-maven-plugin</artifactId>
-        <version>1.1.7-SNAPSHOT</version>
+        <version>1.1.6</version>
         <executions>
           <execution>
             <goals>

Thanks,
-- 
Wendy

Mime
View raw message