archiva-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: proxying was: two 500 errors
Date Sun, 28 Jan 2007 22:04:05 GMT
This seems to be the same problem that a couple of other users have  
reported for /repository. I'm CCing Andy in case he recognises it  
(not sure if he is on this list?).

- Brett

On 29/01/2007, at 4:46 AM, Wendy Smoak wrote:

> On 1/28/07, Joakim Erdfelt <joakim@erdfelt.com> wrote:
>> Those wiki docs are now incorrect.
>> The /proxy/ URL was removed as it didn't support security or  
>> webdav or
>> the ability to upload content on.
>> Having 2 URLs to access the repository was confusing.
>>
>> I'll update the wiki (and the archiva-site docs) to reflect the  
>> current
>> usage.
>
> Okay, with r500200, the /proxy url no longer works.  (There is no
> Action mapped for namespace / and action name proxy.)
>
> However, proxying also does not work with the the /repository URL.
>
> I have central proxied through 'myrepo', and the guest user is a
> repository observer.
>
> 1. rm -rf $M2_REPO/junit
> 2. override 'central' with url http://localhost:9091/archiva/ 
> repository/myrepo/
> 2. quickstart archetype ... mvn install
>
> The build fails due to the missing JUnit dependency, and the  
> Archiva logs show:
>
> INFO   | jvm 1    | 2007/01/28 10:34:01 | WARNING: /archiva/ 
> repository/myrepo/ju
> nit/junit/3.8.1/junit-3.8.1.jar:
> INFO   | jvm 1    | 2007/01/28 10:34:01 |  
> org.codehaus.plexus.component.reposito
> ry.exception.ComponentLookupException: Component descriptor cannot  
> be found in t
> he component repository:  
> org.codehaus.plexus.webdav.DavServerManager (lookup rea
> lm: ClassRealm[plexus.core, parent: null]).
>
> It doesn't look like it's getting as far as trying to proxy.
>
> -- 
> Wendy

Mime
View raw message