apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Knoblauch <kn...@knobisoft.de>
Subject Re: [users@httpd] Problems building httpd-2.4.26 with apr-1.6.2 and apr-util-1.6.0
Date Mon, 26 Jun 2017 08:55:28 GMT
Hi Eric,

 sure this works, but it adds an additional dependency (same with relying
on the system installed version). When expat was bundled with apr-util I
never had to do anything special about it. Likely I never realized that
dependency. So, apr-util-1.6.0 surprised me by breaking a year old build
process.

 So my question now is - was the removal of expat from apr-util
intentional? I see no mentioning in the release notes.

Thanks
Martin

On Fri, Jun 23, 2017 at 6:22 PM, Eric Covener <covener@gmail.com> wrote:

> On Fri, Jun 23, 2017 at 10:55 AM, Martin Knoblauch <knobi@knobisoft.de>
> wrote:
> >  Apparently apr-util no longer bundles "expat". So my question: what is
> the
> > correct/intended way to work around this?
>
>
> apr-util accepts a --with-expat.  If you build apr-util under httpd's
> srclib/ --with-expat can be specified at the top and it will be passed
> down.
>
>
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
------------------------------------------------------
Martin Knoblauch
email: k n o b i AT knobisoft DOT de
www: http://www.knobisoft.de

Mime
View raw message