apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan <luke1...@posteo.de>
Subject testxlate fixes and other patches
Date Wed, 29 Jun 2016 00:36:54 GMT
Hi,

I've spent several hours the past weeks to investigate in more detail
build issues and test failures I run into when building
APR/APR-util/APR-iconv and entered my findings (including patches) in
the bugtracker.

All tests were done on Windows using VS 2015 Update 2 with nmake and the
provided Makefile.win files.
APR versions:
APR 1.5.2
APR-util 1.5.4
APR-iconv 1.2.1

I understand that the cmake builds might not suffer the described issues
and that APR-iconv is somehow deprecated. Still, maybe this might be of
some use to the project.

I'm sending this mail to try to push some awareness on the provided
patches and also as a quick summary/overview of what was added to the
bugtracker:

APR/APR-util: fix for "The system cannot find the path specified"
(SystemRoot case mismatch):
https://bz.apache.org/bugzilla/show_bug.cgi?id=59698 /
https://bz.apache.org/bugzilla/show_bug.cgi?id=59721
APR: testapp crash: https://bz.apache.org/bugzilla/show_bug.cgi?id=59711
APR-iconv: fix for "precompiled object not linked in" (missing obj-file
in linker list): https://bz.apache.org/bugzilla/show_bug.cgi?id=59725
APR-iconv/APR-util: testxlate build script related issues (mostly
related to path/environment variable handling):
https://bz.apache.org/bugzilla/show_bug.cgi?id=59755
APR-util: testxlate UTF-7 issues (test assumption fix):
https://bz.apache.org/bugzilla/show_bug.cgi?id=59756
APR-util: testreslist test failure (Line 255: expected (10), but saw
(20)): https://bz.apache.org/bugzilla/show_bug.cgi?id=59767

Furthermore (in light of a potential bump of the expat version in
APR-util): expat 2.2.0 was released on 06/21/16 containing several
security fixes: http://expat.sourceforge.net/

Regards,
Stefan


Mime
View raw message