apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William A Rowe Jr <wr...@rowe-clan.net>
Subject Is 1.4.x deprecated? (Was: svn commit: r1728973 - in /apr/apr-util/branches/1.4.x: ./ CHANGES)
Date Mon, 08 Feb 2016 17:53:17 GMT
On Sun, Feb 7, 2016 at 8:47 AM, <rjung@apache.org> wrote:

>
> Backport of r1728971 from 1.5.x.
>
> Modified:
>     apr/apr-util/branches/1.4.x/   (props changed)
>     apr/apr-util/branches/1.4.x/CHANGES
>

Is 1.4.x maintained?

The release of 1.5.x introduced an ABI-compatible replacement of 1.4.x.
The last release of 1.4.x was in March, 2012, with the release of 1.5.0
following on August, 2012.

I'd prefer we treat the 1.4.x and prior branches closed upon the successful
release of the compatible successor to that prior release, as there is no
apparent interest in actually releasing code from the 1.4.x branch.  We
now have 2.x trunk, apr-util 1.5.x head and apr 1.6.x and 1.5.x branches
to maintain as it is.

I last raised this question on 22 Dec '15 in response to
Subject: Re: [PATCH] Prevent huge pool allocations for small requests.
Message-ID: <CACsi250Krcshf-8VCebMdrPePW5PViPtWj=
TS7uaSEWccYE2Og@mail.gmail.com>

but it seems this discussion has not yet picked up.

Mime
View raw message