apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: APR-UTIL 1.5.3 rpmbuild error: File not found by glob: apr_dbd_pgsql*
Date Thu, 13 Mar 2014 10:15:18 GMT
On 12 Mar 2014, at 4:52 AM, WR - Widyachacra Rajapaksha | විද්‍යාචක්‍ර
<widyachacra@gmail.com> wrote:
> I'm trying to build apr-util-1.5.3.tar.bz2 which I downloaded from your site. 
> 
> I'm getting the bellow error while building the RPM using rpmbuild -tb apr-util-1.5.3.tar.bz2
and I couldn't find a solution to resolve this from the internet. Now I stuck & can't
seem to figure out what to do next. Your help will be greatly appreciated.
> 
> 
> Distro: CentOS release 6.5 (Final)
> 
> Installed RPM version(s);
> 
> [root@node1 test]# rpm -qa|grep -i apr
> apr-1.5.0-1.x86_64
> 
> I was able to build apr-1.5.0-1.tar.bz2 without any issues.
> 
> 
> Command I tried: #rpmbuild -tb apr-util-1.5.3.tar.bz2
> 
> 
> Error I'm getting:
> ......>
> + exit 0
> Provides: libtool(/usr/lib64/libaprutil-1.la) pkgconfig(apr-util-1) = 1.5.3
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <=
4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
> Requires: /bin/sh /usr/bin/perl /usr/bin/pkg-config libaprutil-1.so.0()(64bit) pkgconfig(apr-1)
> Processing files: apr-util-dbm-1.5.3-1.x86_64
> Provides: apr_dbm_db-1.so()(64bit) libtool(/usr/lib64/apr-util-1/apr_dbm_db.la)
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <=
4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> Requires: apr_dbm_db-1.so()(64bit) libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libdb-4.7.so()(64bit)
libpthread.so.0()(64bit) rtld(GNU_HASH)
> Processing files: apr-util-pgsql-1.5.3-1.x86_64
> error: File not found by glob: /root/rpmbuild/BUILDROOT/apr-util-1.5.3-1.x86_64/usr/lib64/apr-util-1/apr_dbd_pgsql*
> 
> 
> RPM build errors:
>     File not found by glob: /root/rpmbuild/BUILDROOT/apr-util-1.5.3-1.x86_64/usr/lib64/apr-util-1/apr_dbd_pgsql*

The error has happened earlier than this, which has in turn caused the apr_dbd_pgsql part
of apr-util to not build and therefore be missing at the packaging step.

My first suspicion was that there was a missing BuildRequires in the spec file, but this is
there:

%package pgsql
Group: Development/Libraries
Summary: APR utility library PostgreSQL DBD driver
BuildRequires: postgresql-devel
Requires: apr-util = %{version}-%{release}

Can you look in the ./configure stage of the build (earlier than the above) and find the part
where it detects the postgresql libraries, and verify they were detected successfully (they
probably weren't). The config.log file in the build directory will give you the progress of
the configure script, and will give you the details of any error that occurred.

Regards,
Graham
--


Mime
View raw message