apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: APR Util Question
Date Fri, 31 Jan 2014 21:49:04 GMT
On Fri, Jan 31, 2014 at 4:40 PM, Lamb, Joel <Joel.Lamb@ftr.com> wrote:

>  Hi Jeff
>
>
>
> Thank you for the quick response.
>
>
>
> Yes APR has been installed.
>
>
>
> I did an rpmbuild -tb on apr-1.5.0.tar.bz2 and it created the two rpms and
> I installed them.
>
>
>
> Here is the ldd of testall
>
>
>
> ldd testall
>
>         linux-vdso.so.1 =>  (0x00007ffff41ff000)
>
>         libaprutil-1.so.0 =>
> /root/rpmbuild/BUILD/apr-util-1.5.3/.libs/libaprutil-1.so.0
> (0x00007fbe92186000)
>
>         libexpat.so.1 => /lib64/libexpat.so.1 (0x0000003e9de00000)
>
>         libapr-1.so.0 => /opt/vulture/httpd/lib/libapr-1.so.0
> (0x00007fbe91f49000)
>

That's where the apr RPM you created is installed, right?
 (/opt/vulture/httpd)

Does testall run correctly when run outside of the rpmbuild?  (cd to the
directory, run ./testall)




>          libuuid.so.1 => /lib64/libuuid.so.1 (0x0000003e9ca00000)
>
>         librt.so.1 => /lib64/librt.so.1 (0x0000003763800000)
>
>         libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003de2e00000)
>
>         libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003330c00000)
>
>         libldap-2.4.so.2 => /usr/lib64/libldap-2.4.so.2
> (0x0000003765800000)
>
>         liblber-2.4.so.2 => /usr/lib64/liblber-2.4.so.2
> (0x0000003765c00000)
>
>         libc.so.6 => /lib64/libc.so.6 (0x0000003e9ae00000)
>
>         /lib64/ld-linux-x86-64.so.2 (0x0000003e9a600000)
>
>         libfreebl3.so => /usr/lib64/libfreebl3.so (0x0000003de2200000)
>
>         libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fbe91d2c000)
>
>         libssl3.so => /usr/lib64/libssl3.so (0x0000003763c00000)
>
>         libsmime3.so => /usr/lib64/libsmime3.so (0x0000003764000000)
>
>         libnss3.so => /usr/lib64/libnss3.so (0x0000003764c00000)
>
>         libnssutil3.so => /usr/lib64/libnssutil3.so (0x0000003764400000)
>
>         libplds4.so => /usr/lib64/libplds4.so (0x0000003765000000)
>
>         libplc4.so => /usr/lib64/libplc4.so (0x0000003765400000)
>
>         libnspr4.so => /usr/lib64/libnspr4.so (0x0000003764800000)
>
>         libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00000039c6a00000)
>
>         libdl.so.2 => /lib64/libdl.so.2 (0x0000003de2a00000)
>
>         libz.so.1 => /lib64/libz.so.1 (0x0000003e9c600000)
>
>
>
> Thank you again for your help
>
>
>
> *Joel A. Lamb *
>
> Senior Translations Engineer
> Frontier Communications
> 8001 West Jefferson Blvd
> Fort Wayne, Indiana 46804
> (260) 461-2168 (o)
> (260) 403-3095 (c)
> (260) 461-2124 (f)
>
> joel.lamb@ftr.com
>
>
>
> *From:* Jeff Trawick [mailto:trawick@gmail.com]
> *Sent:* Friday, January 31, 2014 4:25 PM
> *Cc:* dev@apr.apache.org
> *Subject:* Re: APR Util Question
>
>
>
> On Fri, Jan 31, 2014 at 3:32 PM, Lamb, Joel <Joel.Lamb@ftr.com> wrote:
>
>  Dev Team
>
>
>
> I couldn't find a list for support or questions, so I hope this is the
> correct list to sent to.
>
>
>
> I'm trying to build apr-util-1.5.3.tar.bz2 which I downloaded from your
> site.  I'm getting an error with testing and I can't seem to figure out
> what to do next.  Any help you can provide will be greatly appreciated.
>
>
>
> OS: Red Hat Enterprise Linux Server release 6.2 (Santiago)
>
>
>
> I was able to build apr-1.5.0.tar.bz2 with no issues.
>
>
>
> Command I'm running: rpmbuild -tb apr-util-1.5.3.tar.bz2
>
>
>
> Error I'm getting:
>
> Loaded freetds driver OK.
>
> Failed to open freetds[]
>
> Loaded odbc driver OK.
>
> [Fri Jan 31 15:22:57 2014] [dbd_odbc] SQLConnect returned SQL_ERROR (-1)
> at dbd/apr_dbd_odbc.c:1131 [unixODBC][Driver Manager]Data source name not
> found, and no default driver specified IM002
>
> Failed to open odbc[]
>
> teststrmatch        : SUCCESS
>
> testuri             : SUCCESS
>
> testuuid            : -./testall: symbol lookup error:
> /root/rpmbuild/BUILD/apr-util-1.5.3/.libs/libaprutil-1.so.0: undefined
> symbol: apr_os_uuid_get
>
> Programs failed: testall
>
> make: *** [check] Error 127
>
> + exit 1
>
> error: Bad exit status from /var/tmp/rpm-tmp.aVaF6n (%check)
>
>
>
> I guess the apr-util test suite is not running against the expected apr,
> resulting in this failure.
>
>
>
> Has apr-1.5.0 been installed?
>
>
>
> Does testall still exist after the failure (/root/rpmbuild/BUILD/...)?
>  Can you use ldd on testall to see which libapr-1.so gets picked up?
>
>
>
>
>
>
>
> Thank You
>
>
>
> *Joel A. Lamb *
>
> Senior Translations Engineer
> Frontier Communications
> 8001 West Jefferson Blvd
> Fort Wayne, Indiana 46804
> (260) 461-2168 (o)
> (260) 403-3095 (c)
> (260) 461-2124 (f)
>
> joel.lamb@ftr.com
>
>
>
>
>
>
>
> --
> Born in Roswell... married an alien...
> http://emptyhammock.com/
>



-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message