apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From olli hauer <oha...@gmx.de>
Subject Re: Issue with apr-1.5.0 on FreeBSD 10beta3
Date Tue, 17 Dec 2013 21:49:49 GMT
On 2013-12-17 21:54, Jeff Trawick wrote:
> On Fri, Nov 22, 2013 at 4:21 AM, olli hauer <ohauer@gmx.de> wrote:
> 
>> On 2013-11-22 00:08, Jeff Trawick wrote:
>>> On Thu, Nov 21, 2013 at 5:48 PM, olli hauer <ohauer@gmx.de> wrote:
>>>
>>>> Hi,
>>>>
>>>> sorry for late response to apr-1.5.0 ...
>>>>
>>>> I've done some tests with apr-1.5.0 on FreeBSD 10 (amd64)
>>>> and it seems there is an issue that breaks apache24.
>>>>
>>>> With apr-1.5.0 apache22 works but apache24 is broken.
>>>> apache starts fine, nothing special in the logs or during
>>>> start with -X but no response is coming back.
>>>>
>>>> apr/apr-util test:
>>>> ========================================
>>>> apr-1.5.0:      all tests passed [1]
>>>> apr-util-1.5.3: all tests passed
>>>>
>>>>
>>>> working configurations (FreeBSD beta3 [1]
>>>> =========================================
>>>> apache22-2.2.26 apr-1.4.8 apr-util-1.5.3
>>>> apache22-2.2.26 apr-1.5.0 apr-util-1.5.3
>>>> apache24-2.4.6  apr-1.4.8 apr-util-1.5.2
>>>> apache24-2.4.7  apr-1.4.8 apr-util-1.5.2
>>>> apache24-2.4.6  apr-1.4.8 apr-util-1.5.3
>>>> apache24-2.4.7  apr-1.4.8 apr-util-1.5.3
>>>>
>>>> broken combinations:
>>>> =========================================
>>>> apache24-2.4.6  apr-1.5.0 apr-util-1.5.3
>>>> apache24-2.4.7  apr-1.5.0 apr-util-1.5.3
>>>>
>>>> All tests where done with MPM worker.
>>>>
>>>>
>>>> FreeBSD 8.4 (amd64) seems OK in all combinations
>>>> FreeBSD 9.2 (amd64) seems OK in all combinations
>>>>
>>>> [1] FreeBSD 10 beta3 with iconv UTF7 patch r258316
>>>> (head/lib/libiconv_modules/UTF7/citrus_utf7.c)
>>>>
>>>> Any hints where to start?
>>>>
>>>
>>> Set LogLevel trace8 and compare good vs. bad.
>>> Start with -X then attach with dtruss and compare good vs. bad.
>>> Get open fds displayed by lsof and compare good vs. bad.
>>> Is connection to client held open?  Get backtraces.
>>>
>>> I just compared 1.4.8 vs. 1.5.0 and didn't see anything that looked
>>> remotely likely.
>>>
>>
>> Small update,
>>
>> The issue is only present if apache24 is build with '--disable-v4-mapped'
>> which should be the default for FreeBSD >= 5.x.
>>
>> Long time ago I've opened a PR since the httpd configure script contains
>> an error https://issues.apache.org/bugzilla/show_bug.cgi?id=53824
> 
> 
> As it turns out, the problem wasn't specific to --disable-v4-mapped.
> 
> This is fixed in httpd trunk r1551685.

...

Thanks for fixing this issue :)
I will test the fixes during the next days.

-- 
Regards,
olli

Mime
View raw message