apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wmr...@gmail.com>
Subject Re: [PATCH/RFC] no more 0.9.x releases or patches
Date Mon, 04 Nov 2013 01:40:14 GMT
Notwithstanding where other consumers sit, +1 from httpd perspective.
On Nov 3, 2013 7:09 PM, "Jeff Trawick" <trawick@gmail.com> wrote:

> apr-0.9.x has a few fixes queued up, but I don't see any reason to release
> them since httpd 2.0.x is retired.
>
> Index: xdocs/index.xml
> ===================================================================
> --- xdocs/index.xml (revision 1538482)
> +++ xdocs/index.xml (working copy)
> @@ -29,15 +29,6 @@
>    <li>APR-iconv 1.2.1, released November 26, 2007</li>
>  </ul>
>
> -<p>The current legacy releases in support of older applications such
> -as Apache HTTP Server 2.0.x are</p>
> -
> -<ul>
> -  <li>APR 0.9.20, released September 16, 2011</li>
> -  <li>APR-util 0.9.19, released October 17, 2010</li>
> -  <li>APR-iconv 0.9.7, released October 11, 2005</li>
> -</ul>
> -
>  </section>
>
>  <section id="1.4">
> @@ -95,24 +86,21 @@
>  </section>
>
>  <section id="0.9">
> -<title>Apache Portable Runtime 0.9.20</title>
> +<title>Legacy 0.9.x Releases</title>
>
> -<p>The Apache Software Foundation and the Apache Portable Runtime
> -Project are proud to announce the General Availability of
> -version 0.9.20 of the APR Apache Portable Runtime library.</p>
> +<p>Legacy releases in support of older applications such
> +as Apache HTTP Server 2.0.x are</p>
>
> -<p>The corresponding version 0.9.19 of the companion APR-util
> -Apache Portable Utility library and version 0.9.7 of the companion
> -APR-iconv library, an alternative portable implementation of the
> -'iconv' library, remain current.</p>
> +<ul>
> +  <li>APR 0.9.20, released September 16, 2011</li>
> +  <li>APR-util 0.9.19, released October 17, 2010</li>
> +  <li>APR-iconv 0.9.7, released October 11, 2005</li>
> +</ul>
>
> -<p>This version of APR is a security and bug fix release, and is
> -provided only for users requiring APR 0.9 compatibility.  Most
> -developers are encouraged to adopt the latest APR 1.x version
> -to ensure the most comprehensive support and access to the latest
> -features and enhancements.</p>
> +<p>These branches are retired, with no additional 0.9 releases
> +planned.  Security patches will not be provided.</p>
>
> -<p>For further details of this legacy release, see the
> +<p>For further details of the last legacy releases, see the
>  <a href="http://www.apache.org/dist/apr/Announcement0.9.html"
>   >official announcement</a>, as well as the
>  <a href="http://www.apache.org/dist/apr/CHANGES-APR-0.9"
> >CHANGES-APR-0.9</a>,
>
> --
> Born in Roswell... married an alien...
> http://emptyhammock.com/
>

Mime
View raw message