apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: gen_test_char build needs some help in the autoconf-based build
Date Tue, 29 Oct 2013 11:44:16 GMT
On Tue, Oct 29, 2013 at 12:22 AM, William A. Rowe Jr. <wmrowe@gmail.com>wrote:

> No... the entire dependency is on excluding it from svn.  Please remember
> that default timestamps in svn are worthless and whatever you checked in is
> platform specific.
> On Oct 28, 2013 7:02 PM, "Jeff Trawick" <trawick@gmail.com> wrote:
>
>> On Mon, Oct 28, 2013 at 7:51 PM, Graham Leggett <minfrin@sharp.fm> wrote:
>>
>>> On 28 Oct 2013, at 11:01 PM, Jeff Trawick <trawick@gmail.com> wrote:
>>>
>>> > apr trunk on Unix:
>>> >
>>> > It gets built then run only after all .o files are generated, so it
>>> doesn't have the expected impact.
>>> >
>>> > .o/.lo/.libs (for gen_test_char) in tools don't get cleaned, so you
>>> may just see the link invocation when you think you're building from
>>> scratch.
>>>
>>> What happens if you delete include/private/apr_escape_test_char.h before
>>> starting the build? Right now the file is checked in, but given that
>>> Windows builds produce different output to Unix builds we may be forced to
>>> rebuild this header each time from scratch.
>>>
>>> Regards,
>>> Graham
>>> --
>>>
>>>
>> The build bombs if apr_escape_test_char.h is first removed.  I guess
>> there's no dependency on generating it first.
>>
>> --
>> Born in Roswell... married an alien...
>> http://emptyhammock.com/
>>
>
1st pass:

remove .h from svn, get it ignored, add this small patch:

Index: Makefile.in
===================================================================
--- Makefile.in (revision 1536672)
+++ Makefile.in (working copy)
@@ -123,6 +123,8 @@
 $(TARGET_LIB): $(OBJECTS) $(EXTRA_OBJECTS)
        $(LINK) @lib_target@ $(EXTRA_OBJECTS) $(ALL_LIBS)
$(APRUTIL_EXPORT_LIBS)

+$(OBJECTS): include/private/apr_escape_test_char.h
+
 install-modules: install-modules-@APR_HAVE_MODULES@

 install-modules-no:

--/--

But perhaps this doesn't do the right thing with out of tree builds (not
tested there).

-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message