apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From olli hauer <oha...@gmx.de>
Subject Re: apr-util and mariadb 5.5
Date Sun, 06 Oct 2013 15:07:48 GMT
On 2013-10-06 16:43, Stefan Ruppert wrote:
> Am 06.10.2013 14:36, schrieb Nick Kew:
>>
>> On 6 Oct 2013, at 11:38, olli hauer wrote:
>>
>>> Has anyone tested to build apr-util-1.5.2
>>> with mariadb-5.5.33a instead of mysql-5.5.34?
>>
>> Is it supposed to work as a drop-in replacement?
>> Do you think it could/should work with the same
>> driver in APR?
> 
> Yes, it works.
> 
> We at MyARM use apr 1.4.2 and apropriate apr dbd drivers from apr-util 1.3.9. We build
against mysql 5.1 and run tests against mysql 5.1, 5.5 and mariadb 5.5.
> 
>>
>>> checking for mysql_init in -lmysqlclient_r… no
>>
>> Evidently it doesn't.  Is that because the API is different,
>> or the library name?  Either way, if that were the only
>> incompatibility it should be easy to work around.
> 
> The current official mariadb client library 1.0 is far away from being source code compatible
with mysql 5.5 client library. Currently we build against mysql and test against both mysql
and mariadb.
> 
> Regards,
> Stefan
> 

Hi Stefan,

Thanks for your testing hint.

Meanwhile we found the issue in mariadb (during ldconfig registration).

-- 
Regards,
olli

Mime
View raw message