apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: missing DAPU_DECLARE_EXPORT flag
Date Mon, 08 Jul 2013 15:10:10 GMT
On Mon, Jul 8, 2013 at 11:06 AM, Ervin Bajramovic <eb@aquasant-mt.com>wrote:

> Hi All****
>
> ** **
>
> I tried to build apr-util on a windows xp and windows 7 pc with mingw but
> it faild on both pcs with this error message:
>

What level of APR?  What level of APR-Util?

IIRC some support for shared MinGW builds that affects APR-Util is in APR
1.5.x (unreleased) but not APR 1.4.x.


> ****
>
> ** **
>
> make****
>
> Making all in xml/expat****
>
> make[1]: Entering directory `/src/apr-util/xml/expat'****
>
> /bin/sh ./libtool --silent --mode=compile gcc -g -O2
> -DHAVE_EXPAT_CONFIG_H   -I.****
>
> /lib -I. -o lib/xmlparse.lo -c lib/xmlparse.c****
>
> /bin/sh ./libtool --silent --mode=compile gcc -g -O2
> -DHAVE_EXPAT_CONFIG_H   -I.****
>
> /lib -I. -o lib/xmltok.lo -c lib/xmltok.c****
>
> /bin/sh ./libtool --silent --mode=compile gcc -g -O2
> -DHAVE_EXPAT_CONFIG_H   -I.****
>
> /lib -I. -o lib/xmlrole.lo -c lib/xmlrole.c****
>
> /bin/sh ./libtool --silent --mode=link gcc -g -O2 -DHAVE_EXPAT_CONFIG_H
> -I./li****
>
> b -I. -no-undefined -version-info 5:0:5 -rpath /usr/local/apr/lib  -o
> libexpat.l****
>
> a lib/xmlparse.lo lib/xmltok.lo lib/xmlrole.lo****
>
> make[1]: Leaving directory `/src/apr-util/xml/expat'****
>
> make[1]: Entering directory `/src/apr-util'****
>
> /bin/sh /usr/local/apr/build-1/libtool --silent --mode=compile gcc -g
> -O2   -DHA****
>
> VE_CONFIG_H -DWIN32 -D__MSVCRT__ -D_LARGEFILE64_SOURCE
> -I/src/apr-util/include****
>
> -I/src/apr-util/include/private  -I/usr/local/apr/include/apr-1
> -I/src/apr-uti****
>
> l/xml/expat/lib  -o buckets/apr_brigade.lo -c buckets/apr_brigade.c &&
> touch buc****
>
> kets/apr_brigade.lo****
>
> /bin/sh /usr/local/apr/build-1/libtool --silent --mode=compile gcc -g
> -O2   -DHA****
>
> VE_CONFIG_H -DWIN32 -D__MSVCRT__ -D_LARGEFILE64_SOURCE
> -I/src/apr-util/include****
>
> -I/src/apr-util/include/private  -I/usr/local/apr/include/apr-1
> -I/src/apr-uti****
>
> l/xml/expat/lib  -o buckets/apr_buckets.lo -c buckets/apr_buckets.c &&
> touch buc****
>
> kets/apr_buckets.lo****
>
> /bin/sh /usr/local/apr/build-1/libtool --silent --mode=compile gcc -g
> -O2   -DHA****
>
> VE_CONFIG_H -DWIN32 -D__MSVCRT__ -D_LARGEFILE64_SOURCE
> -I/src/apr-util/include****
>
> -I/src/apr-util/include/private  -I/usr/local/apr/include/apr-1
> -I/src/apr-uti****
>
> l/xml/expat/lib  -o buckets/apr_buckets_alloc.lo -c
> buckets/apr_buckets_alloc.c****
>
> && touch buckets/apr_buckets_alloc.lo****
>
> /bin/sh /usr/local/apr/build-1/libtool --silent --mode=compile gcc -g
> -O2   -DHA****
>
> VE_CONFIG_H -DWIN32 -D__MSVCRT__ -D_LARGEFILE64_SOURCE
> -I/src/apr-util/include****
>
> -I/src/apr-util/include/private  -I/usr/local/apr/include/apr-1
> -I/src/apr-uti****
>
> l/xml/expat/lib  -o buckets/apr_buckets_eos.lo -c
> buckets/apr_buckets_eos.c && t****
>
> ouch buckets/apr_buckets_eos.lo****
>
> buckets/apr_buckets_eos.c:47:42: error: variable 'apr_bucket_type_eos'
> definitio****
>
> n is marked dllimport****
>
> buckets/apr_buckets_eos.c:47:42: warning: 'apr_bucket_type_eos' redeclared
> witho****
>
> ut dllimport attribute after being referenced with dll linkage [enabled by
> defau****
>
> lt]****
>
> make[1]: *** [buckets/apr_buckets_eos.lo] Error 1****
>
> make[1]: Leaving directory `/src/apr-util'****
>
> make: *** [all-recursive] Error 1****
>
> ** **
>
> I could fix the problem with some help of a friend. Adding the flag
> -DAPU_DECLARE_EXPORT on line 54 in the file build/rules.mk fix the
> apr-util build problem.****
>
> ** **
>
> Regards Ervin****
>



-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

Mime
View raw message