apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [VOTE] Release APR 1.4.7
Date Mon, 06 May 2013 15:52:04 GMT
On 06.05.2013 16:28, Jeff Trawick wrote:
> On Mon, May 6, 2013 at 6:49 AM, Jeff Trawick <trawick@gmail.com
> <mailto:trawick@gmail.com>> wrote:
> 
>     On Sun, May 5, 2013 at 3:40 PM, Eric Covener <covener@gmail.com
>     <mailto:covener@gmail.com>> wrote:
> 
>         confirm test fails on solaris/amd64 too
> 
> 
>     Unless I've missed something, no one has tested on Windows yet.
>      I'll try to test that in the next few hours to see if there is
>     anything else obvious to fix before tagging 1.4.8.
> 
> 
> 1.4.7 built/tested with MinGW shows no regressions from 1.4.6:
> 
>  Failed Tests            Total   Fail    Failed %
> ===================================================
> testdso                     5      4     80.00%
> testmmap                    8      3     37.50%
> testshm                     5      2     40.00%
> 
> testshm passes when run as administrator.  IIRC, testdso doesn't work
> from MinGW until 1.5, and testmmap has a line ending glitch when you
> build from .tar.*z -- some Windows code in the test program expects CRLF
> in a data file.
> 
> With a Visual Studio 2010 build, testsock is failing inconsistently.
>  (no fail, line 234, line 165, now I can't see a failure again ... )
>  Isn't this the sort of issue Rainer reported in the past?

At least I don't remember having seen non reproducable failures for
testsock and didn't report for 1.4.3-1.4.7 (the releases I voted on).
The only failures I get are for testsockets on Solaris but that's an
IPv6 issues that's not new.

> It *seems* that Windows has no regressions that are exposed by the APR
> test suite, but to be more certain I'd need to bang on testsock a lot
> harder with different versions/builds.

Regards,

Rainer


Mime
View raw message