I've explained it. Is the following a bug?

Step 1:

 ./configure --with-apr=/opt/apr-1.4.6 --with-crypto

include/apu.h:#define APU_HAVE_CRYPTO        0

Step 2:

./configure --with-apr=/opt/apr-1.4.6 --with-crypto --with-openssl=/usr

include/apu.h:#define APU_HAVE_CRYPTO        1