apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: [VOTE] Release apr-util 1.4.2
Date Mon, 02 Apr 2012 12:36:23 GMT
On 01 Apr 2012, at 11:06 PM, Stefan Fritsch wrote:

> Sorry for being late, but
> 
> -1
> 
> Works fine if linked dynamically with DSOs.
> 
> But for the static build, httpd segfaults in mod_ssl (backtrace at the 
> bottom of the mail). Since 1.4.1 doesn't compile with 1.4.1 at all, 
> it's hard to say if this is a regression. Have you tried that? I am 
> not sure if it's apr-util's fault or if some of the other libraries 
> produce some strange conflict.
> 
> Configure was:
> 
> ./configure --with-crypto --with-openssl=/usr --with-nss=/usr --with-
> dbm=db --with-ldap=yes --with-berkeley-db=/usr --with-pgsql --with-
> mysql --with-sqlite3 --with-freetds --with-odbc --enable-maintainer-
> mode --prefix=/usr/local/Aprutil1 --enable-nonportable-atomics --
> enable-threads --enable-allocator-uses-mmap --with-apr=/usr/bin/apr-
> config CFLAGS= -gdwarf-2 -g3 -Wextra -Wno-unused-parameter -Wno-
> missing-field-initializers -Wno-sign-compare -Werror=declaration-
> after-statement --disable-util-dso
> configure: WARNING: unrecognized options: --enable-maintainer-mode, --
> enable-nonportable-atomics, --enable-threads, --enable-allocator-uses-
> mmap

Would it be possible to reduce this down to a reproducible set of configure options? The unrecognised
options seem strange, as does "--with-apr=/usr/bin/apr-config" (shouldn't it be apr-1-config?).
What options did you use to try and build httpd?

Given that static builds have in the past not worked at all, this isn't a regression. I just
discovered static builds of DSO code were broken on apr-trunk and have been for some time,
so any improvement is a step forward.

> If configured statically but without openssl, it doesn't compile:
> 
> crypto/apr_crypto.c: In function 'apr_crypto_get_driver':
> crypto/apr_crypto.c:227:5: error: 'else' without a previous 'if'
> make[1]: *** [crypto/apr_crypto.lo] Fehler 1

This is definitely a bug, fixed in r1308318.

> According to CHANGES, the only change is to fix static build, and it 
> fails at that. Therefore the -1.

Just to set expectations, the change in v1.4.2 wasn't to "fix the static build", but rather
to fix a specific compile error during static build that was affecting the Windows people:

  *) apr_crypto: Move the static initialisation of DRIVER_LOAD from
     apr_crypto_init() to apr_crypto_get_driver(), so that we don't lose
     the parameters. [Graham Leggett]

As I pointed out to Greg, I plan to reroll to take into account the fixes from the last few
days.

Regards,
Graham
--


Mime
View raw message