apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Leighton <leigh...@cis.udel.edu>
Subject how to build APR with VS 2010
Date Wed, 05 Oct 2011 20:47:31 GMT
Is there an update to http://apr.apache.org/compiling_win32.html that 
applies to VS 2010, or some other source of info for how to build APR 
with VS2010?  I'm trying to build APR, but so far without luck.  Here's 
the output I get using nmake:

C:\Users\jon\Desktop\apr\apr-util-1.3.12>nmake /f aprutil.mak

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

No configuration specified. Defaulting to aprutil - Win32 Release.
         cd ".\xml\expat\lib"
         "c:\Program Files (x86)\Microsoft Visual Studio 
10.0\VC\BIN\nmake.exe" /
                    /F ".\xml.mak" CFG="xml - Win32 Release"

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

         if not exist ".\LibR/" mkdir ".\LibR"
         cl.exe @C:\Users\jon\AppData\Local\Temp\nm4064.tmp
xmlparse.c
xmlrole.c
xmltok.c
Generating Code...
         link.exe -lib @C:\Users\jon\AppData\Local\Temp\nm46FD.tmp
         cd "..\..\.."
         cd ".\..\apr-iconv"
NMAKE : fatal error U1077: 'cd' : return code '0x1'
Stop.

C:\Users\jon\Desktop\apr\apr-util-1.3.12>

I'm not sure if this means I don't have VS2010 setup correctly, or 
something else.  Thanks for any help with this.

- Jon

Mime
View raw message