apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John L. Poole" <jlpool...@gmail.com>
Subject Segment Fault: apr_palloc() in libapr-1.so.0
Date Fri, 22 Jul 2011 04:42:01 GMT
My instance of Apache has started to segment fault, it occurred around 
June 30, 2011.

Here's my system:
plug src # uname -a
Linux plug 2.6.33.5 #3 PREEMPT Thu Sep 2 07:47:34 PDT 2010 armv5tel 
Feroceon 88FR131 rev 1 (v5l) Marvell SheevaPlug Reference Board GNU/Linux
plug src #

Apache version:
     Installed versions:  2.2.17(2)(07:46:19 PM 07/21/2011)... [listing 
of modules]

I've tried running Apache without any OPTS by remming my APACHE2_OPTS 
variable, this was it is
a simple instance of pure Apache and no modules:
#APACHE2_OPTS="${APACHE2_OPTS} ....."

and I get the same result in the gdb session (see below) with or without 
APACHE2_OPTS, so it
looks like the problem is in apr.

Here's what I have installed:
  dev-libs/apr

      plug src # eix -I apr
     [I] dev-libs/apr
          Available versions:  (1) 1.4.4!t (~)1.4.5!t
             {doc elibc_FreeBSD older-kernels-compatibility +urandom +uuid}
          Installed versions:  1.4.5(1)!t(07:20:04 PM 
07/21/2011)(urandom uuid -doc -elibc_FreeBSD -older-kernels-compatibility)
          Homepage:            http://apr.apache.org/
          Description:         Apache Portable Runtime Library

     [I] dev-libs/apr-util
          Available versions:  (1) 1.3.11!t
             {berkdb doc freetds gdbm ldap mysql odbc postgres sqlite 
sqlite3}
          Installed versions:  1.3.11(1)!t(12:54:25 PM 
07/04/2011)(berkdb gdbm ldap mysql postgres -doc -freetds -odbc -sqlite 
-sqlite3)
          Homepage:            http://apr.apache.org/
          Description:         Apache Portable Runtime Utility Library

Note: I had installed 1.4.4 and had the same problem, so I allowed the 
"unstable" version for the ARM
platform, 1.4.5, to install.

When apr was compiling, I got this warning at the end:

  * QA Notice: The following files contain runtime text relocations
  *  Text relocations force the dynamic linker to perform extra
  *  work at startup, waste system resources, and may pose a security
  *  risk.  On some architectures, the code may not even function
  *  properly, if at all.
  *  For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
  *  Please include the following list of files in your report:
  * TEXTREL usr/lib/libapr-1.so.0.4.4

I've tried going outside of Gentoo's package system and I installed APR 
directly.
I ran ./configure, make test, and make install.  "make test" gave me: 
"All tests passed." before
testing some database tasks which also passed, for the most part.

  Here's my session in gdb which suggests "apr_palloc" is
  where the problem occurs:

     plug apr # gdb /usr/sbin/apache2
     GNU gdb (Gentoo 7.2 p1) 7.2
     Copyright (C) 2010 Free Software Foundation, Inc.
     License GPLv3+: GNU GPL version 3 or later 
<http://gnu.org/licenses/gpl.html>
     This is free software: you are free to change and redistribute it.
     There is NO WARRANTY, to the extent permitted by law.  Type "show 
copying"
     and "show warranty" for details.
     This GDB was configured as "armv5tel-softfloat-linux-gnueabi".
     For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
     Reading symbols from /usr/sbin/apache2...(no debugging symbols 
found)...done.
     (gdb) run
     Starting program: /usr/sbin/apache2
     [Thread debugging using libthread_db enabled]

     Program received signal SIGSEGV, Segmentation fault.
     0x4029c334 in apr_palloc () from /usr/lib/libapr-1.so.0
     (gdb) quit


  Here's the build log for Apache: http://pastebin.com/U6uj4FHj
  Here's the build lof for apr: http://pastebin.com/XRYAtmqu

  I have saved the complete build staging area and can provide any 
portion thereof.

  Unfortunately, back-stepping to older versions of apr is very 
difficult as the
  maintainer basically removed the older versions from being available 
via emerge.

  What can I provide and/or do to help uncover what is causing this 
problem?  Should
  I log a bug?

-- John

Mime
View raw message