apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zeno Davatz <zdav...@gmail.com>
Subject MinGW and Apache and APR
Date Mon, 07 Feb 2011 16:51:21 GMT
Dear G√ľnter

On Mon, Feb 7, 2011 at 5:21 PM, Guenter Knauf <fuankg@apache.org> wrote:

> Am 07.02.2011 15:48, schrieb Zeno Davatz:
>>
>> I get this far
>>
>> C:\Users\zdavatz\software\apr>sh buildconf
>> buildconf: checking installation...
>> buildconf: python version 2.5 (ok)
>> buildconf: autoconf version 2.67 (ok)
>> buildconf: libtool version 2.4 (ok)
>> buildconf: copying libtool helper files using /c/MinGW/bin/libtoolize
>> buildconf: creating include/arch/unix/apr_private.h.in ...
>> autom4te-2.67: m4sugar/m4sugar.m4: no such file or directory
>> autoheader-2.67: failed to run '/c/MinGW/bin/autom4te-2.67': Bad file
>> number
>> buildconf: creating configure ...
>> autom4te-2.67: m4sugar/m4sugar.m4: no such file or directory
>> buildconf: generating 'make' outputs ...
>> buildconf: rebuilding rpm spec file
>>
>> and no "configure" file is created.
>>
>> My MinGW setup is correct as far as I can tell.
>
> hmmm; I did just check with a fresh checkout done from MinGW bash with a
> shell script (since I have no global search path to SVN):
> #!/bin/sh
> export PATH=/c/svn-win32-1.5.6/bin:$PATH
> svn co http://svn.apache.org/repos/asf/apr/apr/trunk apr-HEAD

I will try this.

> and there buildconf ran as fine as with the recent snapshot ...
> was this with latest MSYS/MinGW?

Yes I am using the latest MinGW / MSYS installation.

> I may not have very latest; if you want to
> test with same version I currently use:
> http://people.apache.org/~fuankg/mingw/
>
> Also, please lets move this thread now to the APR list.

Ok, done.

Best
Zeno

Mime
View raw message