apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Re: buildconf fails for APU with MinGW
Date Wed, 16 Feb 2011 15:09:58 GMT
Am 15.02.2011 00:13, schrieb Guenter Knauf:
> Hi all,
> before we get out next version I really would like to get soem configure
> whoes fixed with the 1.4.x/1.3.x branches ...
>
> currently APU buildconf fails for me with MinGW in APR's genbuild.py:
> $ ./buildconf
>
> Looking for apr source in /projects/apr-1.4.x/apr
> Creating include/private/apu_config.h ...
> Creating configure ...
> Generating 'make' outputs ...
> Traceback (most recent call last):
> File "C:/MinGW/msys/1.0/projects/apr-1.4.x/apr/build/gen-build.py", line
> 230, in <module>
> main()
> File "C:/MinGW/msys/1.0/projects/apr-1.4.x/apr/build/gen-build.py", line
> 135, in main
> objects, _unused = write_objects(f, legal_deps, h_deps, files)
> File "C:/MinGW/msys/1.0/projects/apr-1.4.x/apr/build/gen-build.py", line
> 172, in write_objects
> assert file[-2:] == '.c'
> AssertionError
I've added a 'print file' to ./build/gen-build.py line 171 in order to 
see why the AssertionError happens, and this shows:
...
strmatch/apr_strmatch.c
uri/apr_uri.c
xlate/xlate.c
xml/apr_xml.c
/

so seems to me that some paths are not set properly, and we end up with 
a slash only which makes the "assert file[-2:] == '.c'" bail out ...
I've added a hack which skips the slash, and then buildconf can continue 
(and BTW there follows another slash), but of course that doesnt fix the 
root cause why we get slashes instead of filenames ...
I will see if I find some more time to investigate deeper what exaxtly 
fails in 1st place, but if someone who's more familar with gen-build.py 
has some hints what I could try quickly then please let me know ...

Gün.



Mime
View raw message