apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guenter Knauf <fua...@apache.org>
Subject Re: Apache APR build from SVN with MinGW /c/Users/zdavatz/software/apr/xml/expat/configure: No such file or directory
Date Wed, 09 Feb 2011 10:07:44 GMT
Zeno,
Am 09.02.2011 10:45, schrieb Zeno Davatz:
> This time configure failed with:
>
> checking Expat 1.0/1.1... no
>    adding "-L/usr/local/lib" to LDFLAGS
>    setting INCLUDES to "-I/usr/local/include"
> checking Expat 1.95.x in /usr/local... no
>    removed "-L/usr/local/lib" from LDFLAGS
>    nulling INCLUDES
> configuring package in xml/expat now
> /bin/sh: /c/Users/zdavatz/software/apr/xml/expat/configure: No such
> file or directory
> configure failed for xml/expat
>
> As I remember you encountered a similar error.
yes, that's because APR-2 does no longer include expat ... :-(
I tried this:
#!/bin/sh
export PATH=/c/svn-win32-1.5.6/bin:$PATH
svn co http://svn.apache.org/repos/asf/apr/apr/trunk apr-HEAD
svn co 
http://svn.apache.org/repos/asf/apr/apr-util/branches/1.5.x/xml/expat 
apr-HEAD/xml/expat

and ran buildconf.sh && ./configure && make inside the expat folder;
though this gives still linking errors - need to look into that a bit 
closer ...
but even when we pass this prob the next waits already - see my other 
post about break in waitio.c ...

so for now it makes probably more sense to use httpd-2.3.10 package:
http://httpd.apache.org/download.cgi#apache23
I fetched both httpd and httpd-dep packages, and only thing to solve 
then is the pcre dependency ...
but this looks more promising ...

Gün.



Mime
View raw message