apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [VOTE] Release apr-0.9.19 and/or apr-util-0.9.18
Date Mon, 11 Oct 2010 09:35:56 GMT
On 11.10.2010 07:29, Sander Temme wrote:
>
> On Oct 9, 2010, at 7:19 AM, Jeff Trawick wrote:
>
>> Tarballs/zips are at http://apr.apache.org/dev/dist/.  As there are
>> enclosed security fixes (already available separately) and wrowe wants
>> to roll httpd 2.0 soon-ish to get those delivered to the bulk of our
>> 0.9.x users, it would be great to wrap this up within 48 hours.
>> (Comments on timing welcome.)
>>
>> +/-1
>> [+1]  Release apr 0.9.19 as GA
>> [-1]  Release apr-util 0.9.18 as GA
>
> Darwin legadema.sandla.org 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT
2010; root:xnu-1504.7.4~1/RELEASE_I386 i386
>
> No apparent regressions vs. APR 0.9.18 (testsuite output is not easily summarized)
>
> APR-Util fails on linking against libexpat.
>
> Previous APR-Util 0.9.17 had issue with bundled Expat in vpath build: building in the
source tree works and the result of the build passes its tests.
>
> The APR-Util 0.9.18 candidate under test fails also when building in the source tree.
>
> libtool: link: cannot find the library `/UserData/tmp/apr/dist/apr-util-0.9.18/xml/expat/lib/libexpat.la'
or unhandled argument `/UserData/tmp/apr/dist/apr-util-0.9.18/xml/expat/lib/libexpat.la'
> make[1]: *** [libaprutil-0.la] Error 1
> make: *** [all-recursive] Error 1
>
> Looks like xml/expat/lib/libexpat.la did not get created.  Instead, this file lands one
directory higher as xml/expat/libexpat.la, with corresponding artefacts in xml/expat/.libs:

That's intended, the same applies to the other apr-util branches.

> [sctemme@legadema] apr-util-0.9.18 $ ls -l xml/expat/libexpat.la xml/expat/.libs/
> -rw-r--r--  1 sctemme  staff  822 Oct 10 20:42 xml/expat/libexpat.la
>
> xml/expat/.libs/:
> total 1304
> -rwxr-xr-x  1 sctemme  staff  184840 Oct 10 20:42 libexpat.0.5.0.dylib*
> drwxr-xr-x  3 sctemme  staff     102 Oct 10 20:42 libexpat.0.5.0.dylib.dSYM/
> lrwxr-xr-x  1 sctemme  staff      20 Oct 10 20:42 libexpat.0.dylib@ ->  libexpat.0.5.0.dylib
> -rw-r--r--  1 sctemme  staff  459736 Oct 10 20:42 libexpat.a
> lrwxr-xr-x  1 sctemme  staff      20 Oct 10 20:42 libexpat.dylib@ ->  libexpat.0.5.0.dylib
> lrwxr-xr-x  1 sctemme  staff      14 Oct 10 20:42 libexpat.la@ ->  ../libexpat.la
> -rw-r--r--  1 sctemme  staff     823 Oct 10 20:42 libexpat.lai
>
> except some build artefacts still land under xml/expat/lib:
>
> total 904
> -rw-r--r--  1 sctemme  staff  182168 Oct 10 20:42 xmlparse.o
> -rw-r--r--  1 sctemme  staff   58156 Oct 10 20:42 xmlrole.o
> -rw-r--r--  1 sctemme  staff  216604 Oct 10 20:42 xmltok.o
>
> Seems that our 0.9.18 build is looking in the wrong place.  This is a regression: -1.
>
> Has anyone else tested with bundled Expat?

Yes, me :)

Any idea, why the build still tries to look for libexpat.la in 
xml/expat/lib?

Could you please provide:

grep -i expat config.log
grep -i expat Makefile
grep LDFLAGS build/*
grep libaprutil-0 OUTPUT_OF_MAKE_CMD

Regards,

Rainer

Mime
View raw message