apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: svn commit: r1002584 [1/5] - in /apr/apr-util/branches/1.5.x/xml/expat: ./ conftools/ lib/ win32/
Date Thu, 30 Sep 2010 07:44:27 GMT
On Wed, Sep 29, 2010 at 06:59:58PM +0200, Rainer Jung wrote:
> On 29.09.2010 18:32, Rainer Jung wrote:
> >On 29.09.2010 13:52, jorton@apache.org wrote:
> >>--- apr/apr-util/branches/1.5.x/xml/expat/buildconf.sh (original)
> >>+++ apr/apr-util/branches/1.5.x/xml/expat/buildconf.sh Wed Sep 29
> >>11:52:55 2010
> >>@@ -25,7 +25,7 @@ echo "Copying libtool helper files ..."
> >>(cd conftools ; rm -f ltconfig ltmain.sh)
> >>rm -rf aclocal.m4 libtool.m4 ltsugar.m4 autom4te*.cache
> >>
> >>-$libtoolize --copy --automake
> >>+$libtoolize --copy --automake --force
> >
> >Do we actually want that? Now buildconf.sh overrides our svn provided
> >and maintained config.guess and config.sub with the ones installed with
> >libtool, which are often pretty outdated. That might influence
> >negatively the ability to build expat on modern systems.

Hmmm, true.  The --force should not otherwise make a difference to the 
RM process so, that argument seems reasonable.

> >Second question: where do we want the libtool m4 files and aclocal.m4
> >during expat buildconf to be located: in the expat top directory or in
> >conftools? I had the impression you want them now in conftools, but then
> >there are some more fixes in the expat buildconf necessary, at least for
> >libtool 1. I have them ready but want to make sure I understand your
> >intention.
> 
> It looks like acconfig.m4 itself has to stay top level, only the
> included files go to the conftools. Fixed some missing "conftools"
> pathes in the cited revs and included aclocal.m4 in the final
> cleanup.

(Presume you mean aclocal.m4 there - yes, that's picked up by autoconf 
automatically when it is in the same directory as configure.in)

Yes, that looks good, I was just synching up with expat upstream here, 
which set the "MACRO" dir to conftools.  Thanks very much for fixing all 
this up!

Regards, Joe

Mime
View raw message